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Chapter 1

Introduction
In this chapter:
Using this Documentation....................2

Using the Report Designer ...................3
Welcome to the Report Designer. The 
Report Designer is a powerful and flexible 
tool that lets you create all the reports and 
stationery layouts that your business 
needs.

Depending on the Sage program you are 
using, you can create up to four different 
types of documents using the Report 
Designer. These are reports, stationery 
layouts, letters, forms and labels. The 
principles for creating these documents 
are the same.

For this reason, instead of repeating the 
information for all the different document 
types, the User Guide refers only to 
creating and using reports. However, the 
information provided can be used for the 
other types of documents. For example, 
adding text to reports is exactly the same 
as adding text to stationery layouts, letters 
and labels.

The Report Designer provides you with a 
Report Wizard to help you create your 
own reports quickly and easily. You can 
also use the Report Designer to make 
changes to many of the reports supplied 
with your Sage program.



Using this Documentation

This User Guide applies to the Report Designer supplied with all Sage programs.

The examples included in the guide will refer to other programs such as Sage Payroll as 
well as Sage 200. While the examples may be based in another Sage program, the 
concepts and use of the program work in the same way for Sage 200.

We hope you will find the documentation comprehensive. If you want to email us with your 
comments, please email the Sage 200 Documentation Team at 
SageTechnicalAuthors@sage.com and mark the subject line as 'Sage Report Designer'.

Process-oriented approach

This User Guide describes how to use the Report Designer to create reports and 
stationery layouts. For information about accessing and printing the reports and stationery 
layouts supplied with your Sage program, see the documentation supplied with the Sage 
program.

The aim of the examples used throughout this guide is to show you the variety of options 
you can use to customise your Sage reports. While some reports use examples specific 
to a particular Sage product, the features and how they are used apply across the Sage 
product range.

Where the processes comprise of more than one activity, a snapshot of activities is 
provided in the coloured side panel on the first page of all chapters. Where it does not, a 
snapshot of the topics included in the chapter is provided. 

Conventions

References to other sections in this User Guide, or to other guides are given in italics.

References to on-screen items, or items you need to enter, are enclosed in single 
quotation marks. For example, from the 'Report Designer' window 'File' menu, 
select 'New'.

References to highlight where information relates specifically to Sage 200 are 
highlighted using bold.



 Introduction
Using the Report Designer

The types of reports and stationery layouts that you can create using the Report Designer 
depends on the Sage program you are using. The principles of creating these documents are 
the same, so once you get used to creating one type of document, you can create them all.

Sage 200

The Sage 200 Report Designer can be used to create reports and stationery layouts.

However, if you are using a standard report, there are a number of ready-to-use reports. You 
can access these from the Reports folder from each individual module. For example, you can 
access the Aged Creditors report (which shows the debts that you owe to your suppliers by 
date or period) within the Purchase Ledger module.

           

Reports

There are currently over 52 report types, grouped into five report categories in Sage 200. You 
can also create layouts for any of these report types and once you have specified the 
information you want to appear on your report, you can then sort and filter this information as 
required. You can also insert graphic objects, such as rectangles and lines on your reports.

The five report categories are as follows:

Cashbook

General (Discrepancy Reports, Transaction Audit File and VAT Reports)

Nominal

Purchase Ledger

Sales Ledger.
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If you have the Commercials modules installed, you also have access to the following report 
categories:

POP

Pricebook

SOP

Stock
(includes traceability reports for stock items that use batch/serial numbers).

If you use an additional module, such as Sage 200 Wharehouse and Retail or Manufacturing, 
you can also access additional reports for the modules.

Stationery Layouts

Stationery layouts are designed to be printed onto your everyday stationery. When you create 
stationery layouts you can view special layout template files to give you a background image of 
the Sage stationery that they will be printed on. This ensures that your data is printed in the right 
boxes on the stationery.

You can create stationery layouts for:

Statements

Remittances/cheques

Free Text Invoice

EC Sales List.



Chapter 2

The Report Designer Desktop
In this chapter:
Remember.... .......................................6

Report Designer Main Desktop ............7

The Report Designer Toolbar Options ..8

The Report Designer Menu Options...11

Shortcut Keys....................................15
This chapter includes information about 
the options available on the Report 
Designer desktop and in the menus. Use 
this chapter as a reference, for information 
about how to use the various options.



Remember....

....if you have any further queries about any of the procedures or options, use the Report 
Designer Help system.

If you are unsure about what to do on a particular screen, press the F1 function key. The 
procedure associated with the screen you are currently using appears.

The Report Designer Help system includes a glossary of the terms used in the Report 
Designer. To view this glossary, simply click the 'Glossary' button on the help window 
toolbar.

           

To view the 
glossary of terms 
used in the Report 
Designer, click the 
'Glossary' button



 The Report Designer Desktop
Report Designer Main Desktop

When you choose to create a new report from within a Sage application, the Report Designer 
Wizard appears. For more information about the Report Designer Wizard see the section 
Creating a Report Using the Report Wizard in the chapter Creating Example Reports. As you 
become more experienced using the Report Designer you may prefer to open a new blank 
report, and add the titles, variables, totals, groups and sorts manually to create a report.

When you open or edit an existing report, the Report Designer main desktop window appears. 
Use the options on the desktop and in the menus to work with your reports.

           

Information on all of the toolbars, and menu options is contained in the following sections of this 
chapter.

The 'Page Footer' 
section usually 
contains the totals 
for your report

The 'Details' 
section contains 
the body of your 
report

The 'Page Header' 
section usually contains 
the headings of any 
columns on your report

The 'Status' bar 
shows whether your 
report is in Design or 
Preview mode

The 'Main' toolbar 
contains all of the basic 
options that you need to 
work with.

Use the options on the 
'Object' toolbar to insert text, 
variables, lines and boxes on 
your report.

Use the options on the 'Text' 
toolbar to change the 
appearance and style of any 
objects on your report.
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The Report Designer Toolbar Options

Main Toolbar Options

Once you have opened a report, the 'Main' toolbar contains options to help you work with your 
reports. You can create new reports, edit existing ones and send them to your printer. You can 
also move selected objects and undo and redo actions on your reports.

           

Object Toolbar Options

Use the options on the 'Object' toolbar to select objects to insert onto your reports, you can 
also enter text, insert variables and draw objects. The 'Object' toolbar is shown below.

           

Saves any 
changes to 
the report.

Removes the 
selected object 
from the report and 
places it on the 
clipboard for 
pasting into a 
different report.

Pastes any 
objects on the 
clipboard onto 
the selected 
report.

Increases or 
decreases 
the amount 
of page 
viewed

The 'undo' button 
removes the last 
action made to the 
report.

Prints your 
report

Opens an 
exisiting 
report.

Changes the 
design screen 
to 'Conditional' 
view mode.

Aligns and 
resizes two 
or more 
objects

Starts the 
'Report 
Wizard' so 
that you can 
create a new 
report.

Copies the selected 
object onto the 
clipboard so that 
another copy of the 
object can be pasted 
onto the report.

Adds an 
expression 
to your 
report

Draws a 
box on 
your 
report

Displays the list 
of available 
variable tables

Adds a title and 
total for a variable 
when you add it to 
a report

Displays the list of 
variables from the 
selected table that you 
can add to your report

Adds a 
variable 
to your 
report

Draws a 
line on 
your 
report

Adds 
text to 
your 
report

Sorts the 
variable list in 
alphabetical 
order

Displays information 
about an object when you 
move the cursor over it

Enables 
you to 
select 
objects

Enables you to 
select a position 
and add a picture 
to your report



 The Report Designer Desktop
Text Toolbar Options

Using the options on the 'Text' toolbar you can change the style and appearance of the 
variables included on your reports. 

           

Status Bar Options

The 'Status' bar at the foot of the Report Designer window shows whether you are in 'Design' 
or 'Preview' mode. Click the 'Design' tab to work with your report in 'Design' mode. The 
variables appear instead of the data and you can control the look of your report, by adding 
variables, text and graphic objects if required.

           

Click the 'Preview' tab to display your report on screen. This shows exactly how your report will 
look once it is printed. When you preview your report, instead of the variable appearing, the data 
it represents is previewed.

The style list shows the 
text styles currently set 
up for your report

This list shows the font size of 
the object currently selected

Use these buttons to 
align your text (left, 
centre, right)

This list shows the 
name of the font used 
for the object currently 
selected

Use these buttons to change the 
appearance of all objects that have 
the same style to either Bold, Italics, 
Underlined or Overlined

Click the 'Design' tab. 
The report displays in 
Design mode.
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Click the 'Preview' tab to view the report as 
it will be printed
0



 The Report Designer Desktop
The Report Designer Menu Options

Once a report has been opened, or a new one is being created, the Report Designer has seven 
menus. These are the 'File', 'Edit', 'View', 'Format', 'Tools', 'Window' and 'Help' menus. This 
section contains specific information about each menu.

          

File Menu Function

New To create new report.

Open To create an existing report.

Close To close the current report template (but leave the Report 
Designer running).

Save To save the file as the current filename.

Save as To save the file under a new filename.

Send to E-mail Recipient To send your Sage report(s) by e-mail, (only enabled when the 
report is in Preview mode).

Page Setup To set up the paper size, margins and paper source.

Print Setup To set the printer the document is to be printed to.

Print To print the report template.

Print Preview To run the report to preview on screen.

1,2,3,4 The last 4 opened or saved files. You can quickly access the last 
4 opened or saved files that you were working on.

Exit To close out of the Report Designer program.

Edit Menu Function

Undo Undo the last change made to the document.

Redo Redo the last undo.

Cut Remove the currently selected object and place in the clipboard.

Copy Take the copy of the currently selected object and place in the 
clipboard.

Paste Copy the contents of the clipboard to this document.
 11
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Note: All 'Edit' menu options except 'Select All' are disabled when in Preview mode. Click 
'Select All' and all appropriate options are enabled.

          

Clear Delete the currently selected object from this document.

Select All Select all objects on document.

Send to Front If two objects are in the same place, moves selected object in 
front of the other object.

Send to Back If two objects are in the same place, moves selected object 
behind the other object.

Properties Opens the 'Object Properties' for the currently selected object.

Conditional Properties Opens the 'Conditional Object Properties' window for the 
currently selected object, so you can set up a conditional filter.

View Menu Function

Report Design Switch to 'Design' view.

Print Preview Switch to 'Print Preview'.

Conditional View Change the design screen to 'Conditional View' mode, to show 
all objects using conditional formatting.

Toolbars Set up which toolbars are to display.

Browser Show or hide the report browser.

Margins Display margins on screen.

Zoom Increase or decrease percentage zoom of the document on 
screen. The report previews larger or smaller, where 100% is 
actual size.
2



 The Report Designer Desktop
          

Note:With the exception of 'Styles', all Format menu options are only enabled when you are in 
'Design' mode.

          

Format Menu Function

Groups View or add groups to the report.

Sorts Change the way the data is sorted.

Filter Set to exclude certain records or data from the report.

Criteria Enable criteria on the report to filter certain records at run time.

E-mail Change the settings to e-mail report.

Page Allows you to include records with no transactions.

Sections Allows you to view and modify the reports page sections.

Styles View, add, modify and remove various font styles.

Alignment Organise the horizontal and vertical position of selected variables.

Tool Menu Functions

Options Settings for Report and Report Designer.

Variable List Display or Print a list of all tables and variables available with 
current report type.
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Window Menu Function

Cascade Position all currently open windows or reports so that they 
partially overlap each other.

Tile Position all currently open windows or reports one underneath 
the other.

Arrange Icons Arrange icons of all minimised windows or reports along the 
bottom of the screen.

1,2,3,4 If you have more than one report open, they are listed here. 
Select a report to bring it to the front of the desktop so that you 
can view or edit it.

Help Menu Function

Report Designer 
Contents

Opens the Report Designer Help system.

Report Information Print all information (filters, expressions, sections, groups and so 
on) of currently open report template.

About Report Designer Show information about the Report Designer program.
4



 The Report Designer Desktop
Shortcut Keys

To save time, you can use the shortcut keys instead of choosing options from the menus. The 
following key combinations may be used to change the appearance of an object on your report, 
or help you to perform a specific task, for example, saving your report or opening an existing 
one.

          

CTRL+A Selects all the objects (variables, text and graphics) on the report. 
If required, you can then move all these selected objects together 
by using either the arrow keys or the mouse.

CTRL+B Changes the text in the selected objects to bold.

CTRL+C Copies the selected objects to the Report Designer's clipboard. 
The objects are not removed from the report layout. You can 
then paste these objects into any report.

CTRL+I Changes the text in the selected objects to italics.

CTRL+N Starts the Report Wizard. This lets you create a new report.

CTRL+O Opens an existing report.

CTRL+P Prints your report.

CTRL+S Saves any changes you have made to the current report.

CTRL+U Underlines the text in the selected object.

CTRL+V Pastes whatever is held in the Report Designer's clipboard into 
the current report.

CTRL+X Removes the selected objects from the report layout and stores 
them in the Report Designer's clipboard. You can then paste 
these objects into any report.

CTRL+Z Cancels the previous action. This lets you undo mistakes.
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Report Designer Basics
In this chapter:
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Your Sage program contains a whole suite 
of reports and stationery layouts for you to 
use straightaway. However, you can use 
the Report Designer to modify and create 
reports and stationery layouts to meet any 
specific requirements that you have.

This chapter includes information on the 
basic options available when using the 
Report Designer. For information about 
how to create specific reports see the 
Creating Example Reports chapter on 
page 139.



Remember....

....if you have any further queries about any of the procedures or options, use the Report 
Designer Help system.

If you are unsure about what to do on a particular screen, press the F1 function key. The 
procedure associated with the screen you are currently using appears.

If you want more information on a general subject, for example, reports, use the Index 
facility. To do this, select the Index tab from the Report Designer Help system and type 
reports into the space provided.

           

Questions and Answers

The Report Designer Help system also contains a comprehensive Questions and 
Answers section. If you are having problems using the Report Designer, why not have a 
look at this section of the help.

Use the Index tab to 
search for keywords in 
the help system



 Report Designer Basics
Creating Reports

You can use the Report Designer to create all of the reports and stationery layouts your 
business needs. The Report Designer provides you with a Report Wizard to help you create 
your reports. You can use the Report Wizard to add titles, variables, totals, groups and sorts to 
your report. Alternatively, you could just use the Report Wizard to add a title to your report and 
add your variables, sorts, groups and so on manually.

Preparing to create a new report

The first thing you need to consider when creating a report is exactly what the purpose of 
the report is, and what the information is that you need to display.

We advise you to make a note of the information types you want before you start, and 
what order you want them to appear in on your report.

If you are using Sage 200, from the Sage 200 tree menu, click the 'Report Designer' 
option. 

Select the type of report that you want to create, for example, Financials or 
Commercials.

The Report Designer appears.

From the 'Report Designer' window 'File' menu, select 'New'.

The 'Report Designer Wizard' appears, and you are now ready to start creating your 
report.

Adding Variables

Variables are codes that represent specific types of data. When you print your report, instead 
of the variable appearing in the final report, the data it represents is printed. For example, if you 
place the variable object called, NAME on your report, when you print your report, your 
company's name will appear in exactly the same place as you had placed the variable.

Variables are divided into different tables, and the tables that are available vary according to 
which type of report you are creating. For example, if you were creating a Nominal Ledger 
Report, you would only be provided with tables that include information relating directly to the 
Nominal Ledger. This saves you time, as you do not need to search your database to find the 
relevant information for your report.

You can view or print information about the variables that are available for your report at any 
time. For more information about viewing and printing variables see To view or print the variable 
list on page 20 following.

Variables can be added to your report in two different ways:

When you use the Report Wizard to create your report

By adding a variable from the Report Designer window.
 19
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When you use the Report Wizard to add your variables, the variables are added in the report 
layout from left to right in the order that you select them. The Report Designer also automatically 
enters a text heading for each variable for you. Once you have added all of the variables you 
want on your report, you can move them around to meet your requirements.

If you add a variable to your report from the 'Report Designer' window, and then you want to 
add a heading for the variable, you need to add the text for it yourself. For further details on 
inserting text, see Adding Text on page 30, later in this chapter. Alternatively, when adding 
variables you can use the 'Active Complete' option to automatically add titles and totals for your 
variables when you add them to your report. For more information see The Active Complete 
Option on page 28, later in this chapter.

To view or print the variable list

1. From the Object Toolbar, select the 'Sort Variable Lists' option if you want the variable list 
to be viewed and printed in alphabetical order.

2. From the 'Tools' menu, choose 'Variable' List.

The 'Variable List' window appears, showing all the variables available for the table 
selected, together with a description for each. To view the variables for another table, 
select the table you require from the drop-down list.

3. To print out your variable list for the table currently selected, click 'Print'.

To print out a variable list for all of the available tables, click 'Print All'.

The 'Print' window appears.

4. Specify your printing requirements, such as the number of copies you want to print, and 
click 'OK'.

The report is printed.

5. To return to the Report Designer desktop, click 'OK'.
0



 Report Designer Basics
Using the Report Wizard

The Report Wizard guides you through the various options available for your report. Using the 
Sage Payroll program in the following example, we are going to create a report to show a list of 
employees and their department details. The report needs to show the Department Reference, 
Employee Reference, Title, Forename and Surname. This type of report is often useful to help 
you with company tasks that do not necessarily relate directly to Payroll.

In this section you will learn how to:

Use the Report Wizard

Arrange variables on a report

Save and print a report

Manually create a report (recreating the report generated by the Report Wizard)

Add column headings.

For more examples showing how you would use the wizard to create reports see the Creating 
Example Reports chapter on page 139.

To create a report using the Report Wizard

1. From the Sage Payroll main toolbar, click 'Reports'.

The 'Reports' window appears.

2. From the 'Reports' toolbar, click 'New'.

The 'Sage Report Wizard' appears displaying the 'Document Type' page.
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3. From the 'Report' tab, select the 'Employee' option. In the 'Enter a document description' 
box, type 'Departmental Employee List Report' as the description for your report, then click 
'Next'.

The 'Report Variables' page appears.
           

4. From the 'Table' drop-down list, select the 'sgtbl_EmployeePersonal' table.

The 'Variables' list changes to show all the variables available in the 
'sgtbl_EmployeePersonal' table.

5. Click the 'Sort' button to make it easier to locate the variables, and from the 'Variables' list, 
select the 'Department Reference' variable then click 'Add >'. This copies the 'Department 
Reference' variable to the 'Report Variables' list.

6. Add the 'Reference (Employee)', 'Works No', 'Title', 'Forename' and 'Surname' in the 
same way.
2
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           .

If you make a mistake, simply select the incorrect variable from the 'Report Variables' list 
and click '< Remove'. The selected variable disappears from the 'Report Variables' list.

7. Click 'Next'.

The 'Variable Sizes' page appears.

You can use this page to set the number of characters you want the variable to generate, 
and the width of the variables on your report. However, we are not changing the variable 
characters or width on this report, so you do not need to do anything on this page.

8. Click 'Next'.

The 'Groups' page appears. 

You can use this page to group information on your report. However, we are not adding 
groups to this report at this stage, so you do not need to do anything on this page.

9. Click 'Next'.

The 'Sorts' page appears.

10. Select the 'sgtbl_EmployeePersonal.DepartmentReference' variable and click 'Add >'.

The 'DepartmentReference' variable appears in the 'Sort Variables' list.
 23
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11. Click 'Finish'.

The Report Designer window appears, showing your report layout.

Your report layout should look similar to this:
           

Note: To see how your report really looks whilst your are designing, you can click the 
'Preview' tab from the lower status bar below the report, at any time.

You are now ready to arrange your variables.

To arrange your variables
The Report Wizard places all text headings and variables on the report layout from right to left, 
in the order you selected them using the Report Wizard. Therefore, all you need to do is arrange 
these so they are in the correct places, using the drag and drop method, and edit those 
headings where the title for the column may be longer than you require. So for example you may 
want to change 'DepartmentReference' to 'DeptRef'. For more information about editing your 
text, see To edit text on page 32, later in this chapter.
4
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1. To re-arrange your text headers and variables:

To move a variable, click the variable and while holding down the mouse button, drag the 
variable to the required position then release the mouse button. Alternatively, select the 
variable and use the arrow keys to position the variable.

2. Once you have re-arranged your text and variables you need to adjust the height of the 
section. To do this click the lower line of the section you require. Hold the mouse button 
down and drag the section line to the position you require and then release the mouse 
button.

When you have finished, your report layout should look similar to the example shown 
below.

           

You can preview how the report will print by clicking the 'Preview' tab at any time.

Your report preview should look similar to the example here:
           

You are now ready to save and print your new 'Departmental Employee List' report.
 25
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To save and print your report

1. From the 'File' menu, choose 'Save As'.

The 'File Save As' window appears.

2. From the 'Save in' drop-down list, select the folder where you want to store the report.

Tip: If you have installed your Sage Payroll program in the default file location and you save 
this report into your C:\Program Files\Sage Payroll\Reports\Employee folder, it will appear 
in the 'Employee Reports' folder in the 'Reports' window.

3. In the 'Filename' box enter a name for the report.

4. Click 'OK'.

Your report is now saved.

5. To print your report, from the 'Status' bar click the 'Preview' tab. Then from the main 
toolbar, click 'Print'.

The 'Print' window appears.

6. To print your report, click 'OK'.

To create your Departmental Employee List report manually

1. To create your report manually, you can follow steps 1-4 from the To create a report using 
the report wizard section. After you have entered your Report Description, click 'Finish'.

The 'Report Designer' window appears showing your blank 'Departmental Employee List' 
report.

Note: If you do not want to use the 'Active Complete' option throughout the design 
process, click the 'Active Complete' button on the Object toolbar (so it does not appear 
light grey.) This prevents the 'Active Complete' window appearing each time you position 
a variable. For more information, see the The Active Complete Option section later in this 
chapter.

2. From the Object toolbar, click the 'Variable option.

3. From the Table drop-down list on the Object toolbar, select the 'sgtbl_EmployeePersonal' 
table.

The 'Variable' drop-down list at the right of the 'Table' drop-down list now shows the 
variables for the 'Employee_Personal' table you selected.

4. From the 'Variable' drop-down list, select the 'DepartmentReference' variable you want to 
add to the report. Then click in the 'Details' area of the report at the position you want it to 
appear.

The variable is placed on the report.
6



 Report Designer Basics
If you selected to use the 'Active Complete' option before you added the variable, the 
'Active Complete' window appears. For more information, see The Active Complete 
Option on page 28.

5. Repeat this process to add the following variables, 'Reference (Employee)', 'Works No', 
'Title', 'Forename' and 'Surname'.

Note: If a variable does not appear exactly where you want it on your report, then click the 
variable with your mouse and use the arrow keys to move the variable to the new position.

The report layout should now look like the following:
           

Now you have inserted your variables you are ready to add the text for your column 
headings.

Note: All variables are surrounded by a blue line to differentiate them from user defined 
objects which are surrounded with a grey line.

To add column headings

1. From the Object toolbar, click the 'Text' option.

The cursor changes to a cross shape.

2. Click the report layout at the position where you want to insert the text for your column 
heading 'Department Reference'.

Type the words 'Dept Ref' and the text you enter appears surrounded by a box.

Repeat this step to insert your column headings for the other variable columns.

Note: If a column heading does not appear exactly where you want it on your report, then 
click on the column heading with your mouse and use the arrow keys to move it to the new 
position.

3. To change the headings to bold, double-click on the column heading.

The 'Object Properties' window appears.

4. Click the 'Font' tab, and select 'Bold' from the 'Font style' list.

5. To save the font setting, click 'OK'.

Repeat the above steps for all of your column headings.

The report layout should now look like the following:
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You have now finished creating your report. You should now save and print the report as 
required. For more information about saving and printing your report, please see the 
previous To save and print your Departmental Employee List Report section earlier in this 
chapter.

For further examples and more information about manually creating a report, see the 
Creating a Report Manually section in the Creating Example Reports chapter starting on 
page 160.

The Active Complete Option

You can use the Active Complete option to automatically add titles and totals for variables when 
you add them to a report.

To use the Active Complete option

1. From the Object toolbar, ensure the 'Active Complete' option is selected.

Alternatively, from the 'Tools' menu, choose 'Options'. The 'Options' window appears. 
From the 'General' section on the 'Options' tab, ensure that the 'Use active complete' 
check box is selected.

2. Add the variable to your report.

The 'Active Complete' window appears.
8
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3. In the Title section specify where you want the title to appear and enter the text for the title.

If you want the title width to be the same as the value entered in the 'Variable Size' 
section's 'Width' field, select the 'Use variable width for title width' check box. Clear the 
check box and the title width will be the width of the text.

4. In the 'Totals' section, specify which footer sections should include a total.

5. In the 'Variable Size' section, you can change the 'Output Length', specifying the number 
of characters you want the variable to generate, and also change the width setting of the 
variable.

6. Select the 'On completion display the Object Properties window' check box, if you want 
to change the variables properties after completing this window.

7. Select the 'Remember settings for this session' check box if you want the Report Designer 
to use the settings you have entered when you next use this option.

8. Click 'OK'.

If you selected the 'On completion display the Object Properties' window check box, the 
'Object Properties' window appears.

If you did not select the check box then the main Report Designer window appears.

The title and/or total is added to the report.
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Adding Text

You can add as much or as little text to your report as you like. For example, you might want to 
add headings for columns on your report, or messages like, ''Thank you very much for your 
order'' at the bottom of an invoice as shown in the following example. You can achieve this in 
three simple stages, by selecting the text button, placing the text box on the report and then 
entering the text you require.

It is important to know when adding text, that nearly every printer has recommended built in 
margins, which you can change if you require. You can use the Report Designer to show you 
where these areas are when you are designing the report if you want to. They may offer you 
more of a guideline when you are setting out the layout of the report.

To view the margins
With the Report Designer displaying the report in the 'Design' view, from the 'View' menu 
drop-down list, select 'Margins'.

The margins display light grey on the report design. If you add any text in these areas, they 
will still be printed. To remove the margins from view, repeat the procedure to deselect 
'Margins'.

           

To add text to the bottom of an invoice

1. From the 'Object' toolbar, click the 'Text' option. You are now ready to enter your text, 
which we refer to as a text object.

The process we are going to follow here to add some text, ''Thank you very much for your 
order'' to the bottom of an invoice can be used for adding text to any Sage report.

You can work with text objects with autosize turned on or off.

Margins
0
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2. Autosize is turned on for the purposes of this example.

Open the invoice layout that you have chosen to add the text to, in 'Design' view.

Click on the area of the invoice layout where you want the text to appear, and start typing 
your text.

Note: You may prefer to completely remove the delivery address details on the invoice as 
we have done in this example, and replace them with the new text.

           

3. You can edit the text directly in the box until you click on another object or something else 
in the Report Designer.

If you do this and then want to edit the text, select the text box, and click on the text to 
display the insertion point. Use the arrow keys to move around the text and the 'DELETE' 
and 'BACKSPACE' keys to remove text. The 'INSERT' key acts as a switch between insert 
mode and typeover mode.

Autosize turned on Click the cursor on the report layout at the point you want to 
insert text and start typing. The text you enter appears 
surrounded by a box. This box marks the edge of the object but 
is not printed.

As you continue to type, the box automatically extends in size. 
Press the 'ENTER' key to start new lines and continue to type 
for as long as you want. This is the usual way of working with 
text.

Autosize turned off Click the cursor on the report layout at the point you want to 
insert text. Without releasing the mouse button, drag the box 
that appears to the size and shape you want to give to the text 
and then release the mouse button.

An insertion point appears in the box for you to start typing. At 
this point autosize is automatically turned off, so the text 
automatically wraps itself within the boundaries of the box. If 
you type more than can fit into the box, you need to either 
increase the size of the box or reduce the size of the font used.
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4. When you have finished typing text you can format the text by double-clicking on the text 
or choosing 'Properties' from the 'Edit' menu. For information about formatting your text, 
see Changing Object Properties on page 49, later in this chapter.

Alternatively, you could use the Report Designer styles option to change your text format. 
For more information about using styles see To add a new style on page 35, later in this 
chapter.

5. Once you have made the changes to the text that you require, you need to save the 
changes. To save the report using the same name, from the main toolbar, click the 'Save' 
option.

To save the report using a different name, from the 'File' menu, choose 'Save As'.

For more information about saving your report see Saving Reports on page 73 later in this 
chapter.

To edit text

1. From the Object toolbar, click the 'Select' option, then select the box you want to edit.

The cursor changes to a cross shape.

Continuing with the example of adding ''Thank you very much for your order.'' to an Invoice 
Layout, we now want to temporarily add a seasonal greeting, ''We hope you have a Merry 
Christmas and a Happy New Year''.

2. Select the box again.

The cursor changes to a vertical line.

3. Edit the text as required.
           

4. Once you have made the changes to the text that you require, you need to save the 
changes. To save the report using the same name, from the main toolbar, click 'Save'.

To save the report using a different name, from the 'File' menu, choose 'Save As'. You may 
prefer to save the invoice layout with a file name that indicates the invoice layout is to be 
used at Christmas only, rather than re-editing the text on the same layout again once the 
seasonal text is no longer required.

For more information about saving your report see Saving Reports on page 73 later in this 
chapter.
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Text Wrapping

When you add a variable to a report in Design view there are often occasions when the 
information that the report displays is greater in length than the size of the variable on the report.

For example, in Sage Payroll, you can create a report which displays all the employee's notes 
from the Analysis section on the Employee record. To make sure the notes display in full, you 
can select the 'Wrap text' option, and resize the text variable to a suitable size. The text wraps 
within the area you define.

Note: If you do not increase the size of the text variable sufficiently, the text does not completely 
display on your report.

You can also set the 'Wrap text and grow height' option on the text variable's Pos/Size' tab, so 
the variable automatically resizes to fit all the text wrapping. With this option set, the text can 
continuously move onto the next line until all the text is present on the report.

To set text wrapping and grow height

1. Select and double-click the variable that requires the text wrapping.

The 'Object Properties' window appears.

2. Click the 'Pos/Size' tab.

The Pos/Size properties appear.

3. Select the 'Wrap text and grow height' check box. 

The Wrap text check box can now be used.

4. Click 'OK'. 

The text wrapping and automatic text variable resizing is now active.
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The following example shows the report design and the effects on the reports when you select 
the 'Wrap Text' and 'Wrap text and grow height' options.
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Using Styles

The Report Designer supplies several styles that you can use straight away. A 'style' is a set of 
font properties that is given a name and saved. Rather than selecting individual words or groups 
of words and then changing the way they look, you can apply a pre-designed 'style' and apply 
that to the selected text. 

You apply these styles to text or variable objects by selecting the object and then selecting a 
style from the 'Style' drop-down list on the Text toolbar. When you apply a style name to a text 
or variable object, the text displayed instantly takes on those saved font properties. This can 
save a great deal of time when you typeset a report and it also helps to make your final reports 
consistent.

For example, if you always use specific font properties for your company name and address 
(such as Times New Roman, bold, size 12), you can save these font attributes as a style called 
'Address'. The text object automatically takes on the correct font properties.

Tip: If you are using a style of 'None', you can change the properties of a variable without 
affecting any others.

To add a new style

1. From the 'Format' menu, choose 'Styles'.

The 'Style List' window appears, listing the styles which you currently have set up.
           

2. Click 'Add'.

The 'Style Add' window appears.
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3. In the 'Name' box, enter the name of the new style then click 'OK'.

The 'Style List' window reappears, with the name of your new style at the bottom of the list.

4. Select the style you have just added from the list, then click 'Modify'.

The ’Style Font' window appears.
           

5. Use the 'Style Font' window to adjust the following text properties:
          

Font This list contains the range of fonts that your printer can use. 
Select the font you want to use for your style.

Font style This list contains the types of styles that are available for the 
font currently selected. Select the font style you want to apply 
to your style.

Size Select the size of font you require.
6
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6. To save the style settings, click 'OK'.

The 'Style List' window reappears.

7. To return to the Report Designer, click 'Close'.

To edit an existing style

1. From the 'Format' menu, choose 'Styles'.

The 'Style List' window appears.

2. Select the style you want to amend from the list and then click 'Modify'.

The 'Style Font' window appears.

3. Amend the font properties as required.

4. To save the font settings, click 'OK'.

The 'Style List' window reappears.

5. To return to the Report Designer, click 'Close'.

To delete a style

1. From the 'Format' menu, choose 'Styles'.

The 'Style List' window appears.

2. Select the style you want to remove from the list and then click 'Remove'.

A warning message appears.

3. To delete the style, click 'Yes'.

Strikeout Select this check box if you want to have a line drawn through 
the text for this style.

Overline From the drop-down list, select whether to draw a single or 
double line above the text for this style.

Underline From the drop-down list, select whether to draw a single or 
double line below the text for this style.
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Adding Totals

You can add totals to your reports by placing variables in the page footer sections of your 
report. When you place a variable in a page footer section it automatically displays the sum of 
the values contained on the report.

For example, if you were creating a customer report and added a balance variable to the 'Page 
Footer' section it would show the total balance for all customers shown on the report.

If you have set up groups on your report, you can add sub-totals for each group by adding a 
variable to the 'Group Footer' section. For more information, see Grouping Report Information 
on page 114.

To add a total

1. From the Object toolbar, click the 'Variables' option.

2. Select the variable you want to total from the 'Variables' drop-down list.

3. Place the variable in a page footer section of the report.

The variable is automatically totalled.

4. If you copy a variable from a details or page header section to the page footer the variable 
is not automatically totalled. To specify that the variable is to be totalled, double-click the 
variable.

The 'Object Properties' window appears, showing the 'Numeric' tab.

5. From the 'Function' drop-down list, select the 'Sum' option.

6. Click 'OK'.

You have now added a total to your report.
8
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Adding Lines and Boxes

You can use the Report Designer's graphic tools to draw lines or boxes on your report. For 
example you may want to see your totals on a report displayed in a box on the report rather 
than just being underlined, or create check list reports with boxes that can be ticked manually 
when the report is being used.

The lines can be of any thickness and colour and can be solid or dashed. Boxes can be given 
a background colour (fill), pattern and line border. Lines and boxes are referred to as 'graphic 
objects'.

Note: You cannot add lines and boxes to stationery layouts.

To add a line or box

1. From the Object toolbar, click either the 'Line' option or the 'Box' option.

2. Click the report layout at the point you want to insert the graphic object and without 
releasing the mouse button, drag the graphic object to the size and shape you want, and 
then release the mouse button.

If you drop the graphic, you can easily re-size it by clicking once on the object's outline and 
dragging it to the correct size.

To set line properties

1. Double-click the line or box.

The 'Object Properties' window appears, showing the 'Line' information.
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2. On the 'Line' tab, enter the following properties:
          

The object appears in the Preview area showing the properties you have entered.

3. To save your line settings, click 'OK'.

Tip: To make your line extend to the width or height of the report, click the 'Pos/Size' tab 
from the 'Object Properties' window. Then select 'Full Width' or 'Full Height' from the two 
'Size' drop-down lists.

To set box properties

1. Double-click the box.

The 'Object Properties' window appears, showing the information on the 'Box' tab.

Colour From the drop-down list, select the colour you want the line to 
be.

Style Select the style you want the line to take, for example, solid or 
dashes.

Weight Select the thickness required from the list available. If you want 
to enter a thickness not listed here, enter the thickness you 
require in the 'Custom' box.

Custom If you have selected 'Custom' from the 'Weight' list, use the up 
or down buttons to increase or decrease the thickness of the 
line.

Shadow (boxes only) Select this check box if you want to display a shadow effect 
behind the box.

Round corners (boxes 
only)

Select this check box to give a box a rectangular outline with 
rounded corners.
0
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2. On the Box tab, enter the following properties:
          

The object appears in the Preview area showing the properties you have entered.

3. To save your box settings, click OK.

You can also change the printing options and position and size properties for graphic 
objects. For more information, see Changing Object Properties on page 49.

Colour In the 'Colour' area select the background colour that you 
require by clicking on the appropriate colour button.

Pattern In the 'Pattern' area, select the pattern you want to appear on 
top of the background colour. From the 'Colour' drop-down 
list, select the colour of the pattern.

Note: The pattern is only shown when a background colour has 
been selected.
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Adding Pictures

You can use the Report Designer's picture tool to add pictures to your documents. This is 
particularly useful if, for example, you are going to release a report for public viewing or want to 
add a company logo to a report.

You can manually change the size of the image once it is on your document, or proportionally 
resize it using the 'Keep Aspect Ratio' option. You can also set the image to print only on the 
first copy of a document or add a hyperlink to an image if the document is sent as an electronic 
copy. Adding a hyperlink to an image means a direct link to websites, e-mail addresses or other 
details held in the variables within the report tables.

To add a picture to your report

1. From the Object toolbar, click the 'Picture' option.

2. Click the report layout at the point you want to insert the picture. The top left corner of the 
image will start here.

Do not worry about the exact positioning at this stage. You can move the location of the 
picture once it appears on your report.

The 'Open' window appears.
           

3. Select the folder that contains your picture, and then select the picture you want to add to 
your report. You can add pictures with the following formats: JPEG (.jpg or .jpeg), Windows 
bitmap (.bmp), Windows metafile (.wmf) and Icon (.ico).

The picture appears in the preview area on the right side of the Open window.
2
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4. If you want to embed the picture file into the report itself, clear the 'Link to file' check box.

The picture is saved within the report itself. This means that if you delete or change the 
location of the picture file, it still exists within your report. Saving a picture to a report makes 
the report file size larger however, and if you make changes to the original picture you will 
have to add it to the report again.

If you want to link to the picture file, select the 'Link to file' check box.

The picture does not become part of the report. The report is able to show the picture 
every time you run the report by retrieving it from the path you selected earlier. This means 
that the report file size stays smaller, but if you change the location of the picture, the report 
cannot find it and breaks the link. If this occurs, a warning message appears advising you 
of a broken link. To repair the link you need to select the picture's new location.

Note: If you send a report in HTML format by e-mail that uses a linked picture, the Report 
Designer sends a copy of the picture(s) used with the report. The recipient of the e-mail 
should save all the files into the same folder, and the links remain intact.

5. Click 'Open'.

The picture appears on your report.
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If you want to change the position of the picture, select the picture (8 small black squares 
appear around the picture), and without releasing the mouse button, drag the picture to 
the position you require on the report.

To set picture properties

1. Double-click the picture on your report design view.

The 'Object Properties' window appears.

2. You can use the object properties to affect the picture in a number of different ways.
4
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Hlink Using this tab, you can set up a hyperlink for your picture. For 
example, you can enable someone reading an electronic copy 
of the report to click a picture which takes them to a website of 
your choosing. For more information, see the Setting hyperlink 
properties section later in this chapter.

Options Select 'Print on first copy only'
If you print more than one copy of your report, you can specify 
that you want the picture to appear just on the first copy. Select 
the 'Print on first copy only' option.

If you want the picture to print on every copy make sure you 
clear the 'Print on first copy only' check box.

'Select 'Suppress printing'
You can also prevent the picture from being printed on any 
copies of the report by selecting the 'Suppress Printing' option.

Pos/Size When you add a picture to your report, the height and width of 
the picture are identical to the dimensions you saved originally 
with the source image.

Select 'Keep Aspect Ratio'
If you adjust one dimension such as the height of the picture, 
the other dimension (width) changes automatically and vice 
versa when you select 'Keep Aspect Ratio'.

Select the picture you want to resize. Eight black boxes appear 
around the picture. Hover the mouse over one of the black 
boxes until the mouse pointer changes to a double ended 
arrow. Drag the mouse to increase or decrease the picture size. 
The picture resizes and keeps its original proportions.

If you prefer to manually adjust a value for one of the 
dimensions such as 'Width' the other dimension value (Height) 
automatically adjusts and vice versa.

Clear 'Keep Aspect Ratio'
If you change any of the 'Size' options within the Dimensions 
section, you cannot use the 'Keep Aspect Ratio' facility.

If you want to adjust the 'Width' and 'Height' values manually, 
or drag the picture to the size and shape you want without it 
automatically amending the proportions, clear the 'Keep Aspect 
Ratio' check box.
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Using Objects

An object refers to any item that is placed on a report, whether it is a piece of text, a variable or 
a graphic object such as a line or box.

You can move objects using the mouse or the various options within the Report Designer.

This section covers the following topics:

Selecting, moving and resizing objects

Aligning and resizing multiple objects

Autosizing objects

Anchoring objects.

Selecting, Moving and Resizing Objects

You can select all of the objects on your report or specific objects. This is useful if you want to 
select a number of objects to align simultaneously.

To select, move and resize objects

1. Select the object or objects as follows:

To select an object, click once with the left mouse button on the object required, or 
press the TAB key until the object is selected.

To select multiple objects, hold down the SHIFT key continuously while clicking on the 
objects required. Alternatively, click the 'Select' option from the toolbar, and by 
holding down the mouse button drag the box over the objects you require.

2. Using the arrow keys, move the object(s) to the new position on your report.

Alternatively, hold down the mouse button and drag the object(s) to the position you 
require.

3. To resize an object, select the object and then move the cursor over the horizontal line on 
the right hand side of the graphic until a two-way arrow appears. Hold down the mouse 
button and drag the object to the size you require.
6
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Aligning, Resizing and Justifying Multiple Objects

To save you manually aligning and resizing each object individually, you can use the Align and 
resize button on the Main toolbar or the Alignment option from the Format menu, and resize 
several objects at one time. You can align your objects either horizontally or vertically.

The resize option is useful for adjusting the size of multiple objects. For example, if you want all 
the address variables on a report to be the same size, you can adjust just one of the address 
variables to the size you require, select the remaining address variables and use the Align and 
resize button on the Main toolbar.

You can also justify your object(s) on the report to change the appearance of the information 
within the object. There are three types of justification: left, right and centre.

To align or resize multiple objects

1. Select the objects you want to align or resize.

2. From the main toolbar, click 'Format' and then select 'Alignment'.

The 'Alignment' window appears.
           

3. To align objects horizontally, from the 'Horizontal' drop-down list, specify how you want to 
align them, either from the left, centre or right. Then, using the 'From' drop-down list, select 
where you want the alignment to start.

To resize all objects to the same width as the object with the smallest width, from the 
'Horizontal' drop-down list select 'Width Min'. To resize all objects to the same width as 
the object with the greatest width, from the 'Horizontal' drop-down list select 'Width Max'.

4. To align your objects vertically, from the 'Vertical' drop-down list, specify how you want to 
align them, either from the top, centre or bottom. Then using the 'From' drop-down list, 
select where you want the alignment to start.

To resize all objects to the same height as the object with the smallest height, from the 
'Vertical' drop-down list select 'Height Min'. To resize all objects to the same height as the 
object with the greatest height, from the 'Vertical' drop-down list select 'Height Max'.

5. To save your alignment and resizing settings, click 'OK'.
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To justify your object(s)

1. Select the object(s) you want to justify.

2. From the text toolbar, select the appropriate justification button
           

The information in the object justifies to the selected position.

In the examples above, you can see that the text justifies to the left side, the centre or the 
right side of the object box depending on which justification button you select.

Autosizing

When you enter text into a report the object border will cut off the text if you either type too much 
text or the text box is too small. Usually you would have to resize the text box so that all of the 
text appears on your report.

If you use the autosizing option and you change the font of the object, the Report Designer 
recalculates the size of the object so that the text does not get cut off.

To set up autosizing for an object

1. From the report layout, double-click the object you require.

The 'Object Properties' window appears.

2. Click the 'Pos/Size' tab.

3. Select the Auto size check box.

4. To save your changes, click 'OK'.
8
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Anchoring Objects

You can anchor objects on a report layout to ensure they are not moved. This is particularly 
useful if you are using pre-printed stationery. Once you have placed an object on the report 
layout so that it prints in the correct place on the stationery, you can anchor the object to ensure 
it does not get moved accidentally.

To anchor an object

1. From the report layout, double-click the object you require.

The 'Object Properties' window appears.

2. Click the 'Pos/Size' tab.

3. Select the 'Locked' check box.

4. To save your anchor, click 'OK'.

Changing Object Properties

You can modify the properties of the variable, text and graphic objects on your report. The 
properties you can change depends on the type of object selected. You can change the 
numeric, text, date, time, hyperlink, printing, size and position properties of an object.

Note: If you amend an object's properties, this overrides any default settings which have been 
made for the report. For more information about changing the default settings for your report, 
see the Changing Your Default Report Settings chapter on page 91.

This section covers the following topics:

Updating the object properties of multiple objects

Setting numeric properties

Setting text properties

Setting date properties

Setting time properties

Setting hyperlink properties

Setting printing properties

Setting size and position properties.

For information about setting line and box properties, see Adding Lines and Boxes on page 39.
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Updating the object properties of multiple objects

To save you updating an object's settings individually when a change needs to affect more than 
one object, you can select multiple objects and change the setting once. The changes you 
make to the object properties only affects the relevant variables. For example, if you amend the 
date setting, only date variables are affected. If you wanted to change the decimal precision of 
a number of numeric fields, you could select the numeric fields, set the 'Decimal Places' option, 
and update all the selected objects together.

To update the object properties of multiple objects

1. To select multiple objects from the report layout, hold down the SHIFT key continuously 
while clicking the objects required.

The selected objects are highlighted with small black boxes.
           

2. From the report layout, double-click on any of the selected objects.

The 'Object Properties' window appears.

3. From the 'Object Properties' window, amend the settings as required, and click 'OK'.

The selected objects are updated with the new settings.

Note: For more information about changing the object properties settings, see the 
following topics covered in Changing Object Properties on page 49.

Setting Numeric properties

Setting the properties of the numeric variables on your report ensures that your values are 
presented accurately using the correct symbols and decimal precision where required. Once 
you add a variable, the numeric properties also give you the opportunity to change its function 
quickly and easily.

For example, if you have a column of values and you later decide to edit the report and want to 
see a total of the values, you can quickly add the same variable into the footer section of the 
report, and change its numeric properties to 'Sum'.

Multiple selected objects
0
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To set an object's numeric properties

1. From the report layout, double-click the object you require.

The 'Object Properties' window appears, showing the 'Numeric' information.
           

2. From the 'Function' drop-down list, select the option you require.
          

Sum Select this option to print the sum of the variable. If the variable 
is in a footer section then it will show the total amount for all 
values in the section above it. If the variable is in a details or 
group header section, it will show the running total of the values 
on the report.

Average Select this option to print the average value of the variable. If the 
variable is in a details section, it will show the average value as it 
moves down the list of values.

Min Select this option to print the minimum value of the variable. If 
the variable is in a details section, it will show the variable's 
minimum value as it moves down the list of values.

Max Select this option to print the maximum value of the variable. If 
the variable is in a details section it will show the variable's 
maximum value as it moves down the list of values.
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Note: The Report Designer highlights all objects using functions with a magenta border to 
make it easier for you to identify them when working in report design mode.

3. Enter the following settings to indicate the numeric properties you require:
          

Count Select this option to show the number of transactions on the 
report (or within each group if you have groups set up).

This means that the value of the variable is replaced by the 
number of times the variable appears in the report (or group). If 
the variable is in a details section, it shows the number the 
transaction is in the list.

Count All Select this option, in conjunction with the 'Cumulative' option, if 
you have groups set up to show the number of transactions in 
the whole report.

This means that the value of the variable is replaced by the 
position number of the variable in the report, not in the group.

Sign after group Normally, you only use this option if you have separate debit 
and credit columns on your report.

If you apply a sign to a value, the total shown is calculated by 
adding the debit and credits. For example:

DR  CR

100   0

    0  50

50  0

If you do not apply a sign, the totals for the debits and credits 
columns are calculated separately. For example:

DR  CR

100   0

0  50

100  50

From the drop-down list, specify when you want to apply the 
sign.
2
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4. From the 'Sign' drop-down list, select which sign you want for the variable as follows:
          

Cumulative From the drop-down list, select whether you want running 
totals over different groups.

You can use this option in conjunction with the 'Count All' 
option from the 'Function' drop-down list to show the number 
of transactions in your whole report.

Suppress if zero Select this check box if you do not want to print a value of zero 
for the variable.

Note: If you select this check box, the Report Designer still 
prints the line of the report, but does not print a zero.

Fixed currency 
symbol

Select this check box if you want the currency symbol entered 
in the 'Currency symbol' box, to appear in a fixed position for 
the variable.

Display leading zero From the drop-down list, select whether to show a decimal for 
the variable with a leading zero or without (either as 0.1 or .1).

Decimal places From the drop-down list, specify how many decimal places you 
want to display for the variable.

Numeric format From the drop-down list, select the numeric format you require 
for the variable.

Signed Select this option to print the value and the sign.

Unsigned Select this option to turn off the sign. So, if you are totalling 
positive and negative values, the Report Designer treats all 
values as if they were positive.

Reversed Select this option to reverse what appears for the variable.

Debit Select this option to change the variables value to zero if the 
value is negative. If the value for the variable is positive, then the 
value is displayed.

Credit Select this option to change the variables value to zero if the 
value is positive. If the value for the variable is negative, then the 
value is displayed.

Debit/Credit Select this option to show the value with either a Dr or a Cr 
alongside.
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5. From the Symbols section, specify the symbols you want to use as follows:
          

6. In the 'Component' section, use the options to change how your numeric values are 
displayed.

          

7. To save your settings, click 'OK'.

Note: You can also amend the text, options and position/size properties of your numeric 
variable. For more information about these, see the sections To set an object's text 
properties, To set an object's printing properties and To set an object's position and size 
properties, later in this chapter.

Thousands symbol Enter the symbol you want to use to separate the thousands for 
your variable.

Negative symbol Enter the symbol you want to use for negative amounts.

Decimal symbol Enter the decimal symbol you want to use to for your variable.

Currency symbol Enter the currency symbol you want to use for your variable.

Part From the drop-down list, select which part of your numeric 
value is displayed. As a default it will be set to 'Whole'. 
However, if you are displaying large numeric values and only 
want to show the figures in thousands, select 'Thousands' from 
the drop-down list. The value displayed is the last digit of the 
whole thousand. For example, 12,000 will show as 2.00 and 
150,000 will show as 0.00.

Display From the drop-down list, select how you want the numeric 
value to be displayed. You can display the value numerically or 
as a written amount.
4
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Setting text properties

Changing the text properties of an object offers more opportunity to make the information on 
your report more meaningful for the recipient of the report.

For example, you may want important information to appear in bold or italics, on a report. Your 
company might also use a particular font for all its correspondence which can be standardised 
on the reports you produce using the Report Designer.

To set an object's text properties

1. From the report layout, double-click the object you require.

You can select more than one object by holding down the SHIFT key continuously while 
clicking on the objects required, and then double-clicking on any of the selected objects.

The 'Object Properties' window appears, showing the 'Font' information.
           

2. Complete the boxes as follows:
          

Font This list contains the range of fonts that your printer can use. 
Select the type of font you want to use for your text.

Font style This list contains the styles that are available for the font 
currently selected. Select the font style you want to apply to 
your text.

Size Select the size of font you require.
 55



Sage Report Designer User’s Guide

5

3. To save the text settings, click 'OK'.

The 'Update Font Settings' prompt appears.

4. Select whether to update the changes to all objects with the style or just update the 
selected objects.

The style changes appear.

Note: If you do not want to see the 'Update Font Settings' prompt in future, select the 'Do 
not show this message again' check box. Any font change updates made in the future, 
default to your last prompt choice.

To change the default, see the Changing Your Grid Settings, Measurement Units and 
Other General Options section in the Changing Your Default Report Settings chapter 
starting on page 93.

Strikeout Select this check box to draw a line through your text.

Overline From the drop-down list, select whether to draw a single or 
double line above your text.

Underline From the drop-down list, select whether to draw a single or 
double line below your text.

Text colour From the drop-down list, select the colour you want your text to 
be.
6
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Setting date properties

Changing an object's date format offers you the opportunity to use formats that might have 
been set as a Company preference for reports, or are simply just your personal preference.

For example, you may prefer to see the month referred to using its first three letters rather than 
its month number.

To set an object's date properties

1. From the report layout, double-click the date variable you require.

The 'Object Properties' window appears, displaying the 'Date' information.
           

2. Complete the boxes as follows:
          

3. To save your date settings, click 'OK'.

Date format From the drop-down list, select the date format you require.

Date separator Enter the character you want to use to separate both the day 
from the month, and the month from the year when using a 
short date format. For example, you could use / or a hyphen.
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Setting time properties

The time object properties offers you the choice of different formats for the time information on 
a report. For example, you may prefer your time format to be in 24 hour clock format to quickly 
tell at a glance if a report has been run off in the morning or afternoon.

To set an object's time properties

1. From the report layout, double-click the time variable you require.

The Object Properties window appears, displaying the 'Time' information.
           

2. Complete the boxes as follows:
          

Use 24 hour clock Select this check box if you want to use the 24 hour clock 
format.

Apply zeros to time Select this check box if you want all time variables to consist of 
six digits, for example, if the time was 9.30am this would 
appear as 09.30.00.

AM Enter how you would like AM to appear on your report. For 
example, AM or am.

PM Enter how you would like PM to appear on your report. For 
example, PM or pm.
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3. To save your time settings, click 'OK'.

Setting hyperlink properties

Setting up an object on your report with hyperlink properties, can provide very useful additional 
information for anyone receiving and viewing the report, and all provided within the confines of 
the report.

For example, if you were e-mailing an Invoice to a customer, you could set up a hyperlink for 
your 'Company Name' variable. This could take the customer to your company website when 
they clicked on the company name on the report. Alternatively, you might like to have the 
'Contact Name' variable on a report set up with a hyperlink for an e-mail address.

To set an object's hyperlink properties

1. From the 'Design' view of your report, double click the object you want to set up a hyperlink 
for.

The 'Object Properties' window appears.

2. Select the 'HLink' tab, displaying the 'Hyperlink Source' section.
           

3. Complete the section as follows:

Time separator Enter the character you want to use to separate the hours from 
the minutes. For example, you could use a colon or a full stop.
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4. Click 'OK', and from the report layout, preview your report.

The report preview appears.

5. From the 'File' menu, select 'Save'.

If the report is a non-fixed report, and you select 'Save', the changes you have made 
automatically overwrite the existing report, and so no additional Save window appears.

If the report is a fixed report, it cannot be over written and so you must save the amended 
report using a new filename. The 'Save As' window appears, and the following steps must 
be followed.

6. From the 'Save in' drop-down list, select the folder where you want to store the report.

7. To save your report under a different file name, enter a new name in the File name box.

8. From the 'Save as' type drop-down list, select HTML Files (*.htm), and click 'Save'.

You have now completed entering your hyperlink settings. When you preview your report 
to HTML output, the hyperlinks are activated for you to use.

No Hyperlink Selected by default, but you should also select 'No Hyperlink', if 
you want to remove a hyperlink from a selected object.

Table/Variable Select this option if you want to create a hyperlink using a value 
held in a specific 'Table' and related 'Variable' on a report. The 
tables available vary depending on the type of report you are 
using.

Hyperlink Target Select this option to enter your own text to create a hyperlink on 
your report, For example, http:\\ and mailto:
0
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Setting printing properties

Setting the printing properties for an object is particularly useful for hiding elements of the design 
from the final report print out.

For example, you may want to add some additional design help notes on a report design view, 
but obviously do not want to see these on the printed report itself. You can set the text field to 
be suppressed when printing, so the text does not print.

To set an object's printing properties

1. From the report layout, double-click the object you require.

The 'Object Properties' window appears.

2. Click the 'Options' tab.

The Options information appears.
           

3. Use the following options to indicate the printing properties for this object:
          

Print on first copy only Select this check box, if when you print more than one copy of 
this report, the object only prints on the first copy.

Suppress printing Select this check box if you do not want the object printed on 
your report.

Suppress duplicates From the drop-down list, select whether you want the object 
repeated on your report.
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4. Depending on the forms you may print, for example bank cheques, select from the 
following options.

          

5. To save your settings, click 'OK'.

Setting size and position properties

During the design of a new report or editing an existing report, you may find that information is 
not being displayed in full or the spacing between variables needs adjusting.

In design view, you can use the size and position properties of an object, to move the object 
precisely using measurement units, and control the number of characters that an object 
displays.

To set an object's size and position properties

1. From the report layout, double-click the object you require.

The 'Object Properties' window appears.

2. Click the 'Pos/Size' tab.

The position and size information is displayed.

Fill character Enter a character that you want to include to fill in the gaps in a 
field. For example, you may be printing cheques and need to fill 
in any gaps to avoid fraud.

Entering * would create ***100.00. Entering # would create 
###100.00.

Fill mode From the drop-down list, select a fill mode to specify where you 
want the fill character to appear in the field. For example, Pre-fill 
would be ***100.00, Post-fill would be 100.00*** and Surround 
would be ***100.00***.

Fill format Enter how many characters you want to include in total, 
including fillers. If the fill mode has been set to 'Surround', the 
fill format works on the nearest even number.

For example Surround 1, 2 or 3 would give *100*. Surround 4 
or 5 would give **100**.

Selecting 'Default' allows the maximum amount possible 
available for the field.
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3. Enter the following information in the Position section as required.
          

4. Enter the following information in the 'Dimensions' section as required.

Horizontal Enter the distance the object is placed from the setting you 
specify in the 'From' box.

From From the drop-down list, select where the horizontal distance 
starts from.

Vertical Enter the distance the object is placed from the setting you 
specify in the 'From' box.

From From the drop-down list, select where the vertical distance 
starts from.
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5. Select the following information in the 'Character Output' section as required:
          

Width Enter the width of the object. Use the up/down buttons for fine 
adjustment if necessary.

Size From the drop-down list, select the width of the object as 
follows:

'None' means it will use the measurement entered in 
the Width box

'Full Width' means the object's size will be increased 
to fill the width of the page

'Width' means the object's size will be increased to fill 
the width of the page starting from where the object 
was originally placed.

These options are generally only used for graphical objects 
such as lines and boxes. For example, you could choose the 
'Full Width' option to extend a line to the width of the report.

Height Enter the height of the object. Use the up/down buttons for fine 
adjustment if necessary.

Size From the drop-down list, select the height of the object as 
follows:

'None' means it will use the measurement entered in 
the Height box

'Full Height' means the object's size will be increased 
to fill the height of the section where it is placed

'Height' means the object's size will be increased to fill 
the height of the section starting from where the object 
was originally placed in the section.

These options are generally only used for graphical objects 
such as lines and boxes. For example, you could choose the 
'Full Width' option to ensure that the height of a box matches 
the height of the section.

Use Output Length Select the check box to enter an output length.
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6. Select the following check boxes as required.
          

7. To save your settings, click 'OK'.

Output Length Use the up or down buttons to set the length of a variable or 
expression on your report. The length is measured in terms of 
characters.

Note: You should also select 'Auto size', to ensure that the 
variable is resized on screen to fit the new number of 
characters.

If the 'Use Output Length' box is not selected, the field lengths 
are determined by the data length.

Locked Select this check box to fix the variable in this position on the 
page.

Auto sizing Select this check box to activate auto sizing, or clear it to turn it 
off.

Note: For further information about auto sizing see Autosizing 
on page 63.
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Setting Conditional Properties

You can use conditional formatting when you want to format an object based on its value or 
that of another variable.

For example, in Sage 200, you can set up a Cash Book report which displays any bank account 
balances that have fallen below a specified amount. You can also enable information messages 
to appear when objects meet certain conditions. For example, if the value of the bank account 
field falls below a specified amount, you can display a warning message, 'Warning - Bank 
account balance below £x.xx'.

To set up conditional formatting
The following example uses a Sage 200 Cash Book report. This example shows how you can 
change the way that a field is represented in a report, when certain conditions are met. In this 
example, the account balance of any bank account that is less than £2500 will be displayed in 
the report in a different.

1. Select the report that you want to edit. In this example we will be editing the Cash Book 
report, 'Cash Book Account Details Report.srt'.

2. Select the 'Conditional View' from the 'View' menu to highlight any conditional changes 
that you make to the report.

If the report has no conditional formatting on it, a message will appear; 'There are no 
objects with conditional properties set. The conditional view will appear the same as the 
normal view'. Click 'OK' to continue.

3. On the report layout, select the object that you want to apply conditional formatting to and 
double-click. In this example, the field to select is the one next to the 'Current Balance' 
field, named 'CBAccount.CurrentBalanceInAccntCurrency'.

The 'Object Conditional Properties' window appears.

4. Click 'Build'.

The 'Filter Builder' window appears.

5. From the 'Variables' table, select the variable(s) that you want to involve in the filter.

For example, this report needs to be able to recognise all bank account balances below 
£2500. Select and double-click the 'CBAccount.CurrentBalanceInAccntCurrency' variable 
so that it appears in the 'Filter calculation' box. Select the '<' symbol from the 'Operators' 
drop-down list and click Add. Next, move to the 'Filter calculation' box and enter the value 
2500.

Note: If you know that name of the variable, you can type the filter calculation manually into 
the box.
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6. Click 'OK', and you are returned to 'Object Conditional Properties' window.

The first part of the condition is now set up. The next stage involves setting up the 
formatting effects you want to show on the report when the filter is in use. In this example, 
when an account balance value is less than £2500, it needs to be displayed in a different 
font, in italics and in maroon.

7. To set up the formatting effects, select the 'Font' tab.

The Font information appears.

8. Change the font details. For the purposes of this example, the 'Font style' is changed to 
Italic and the 'Text colour' is changed to 'Maroon'.

9. Click 'OK'. The text for the edited field is now displayed in coloured italics.

Next, we can add some text as an additional warning against any bank account balance 
that falls below £2500.
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To add some conditional information text
To see additional information or a warning message on a report when certain object criteria are 
met, you can apply conditional formatting to text objects. For example, instead of changing the 
font and style of the sales balance when it is less than £2500, a warning message could appear 
against the value, or the message could appear in addition to other conditional changes.

1. Open the report, set it to conditional view and add the text you require for the message to 
your report.

You can then position the text box where you want the text to appear. In this example, the 
'Criteria 2' line has been moved down from the original report allowing for the text to be 
added underneath the 'Last Statement Balance' field.

           

2. Double-click on the text object.

The 'Conditional Object Properties' window appears.

3. To add your filter, follow steps 3-5 of the 'To set up conditional formatting' procedure. 
Continue with steps 6 and 7 from that procedure if you want to format the font details, and 
click OK. In this example you would set the same Filter; 
'CBAccount.CurrentBalanceInAccntCurrency < 2500'.

4. Select the text box, and click on the right-hand mouse button.

5. Select the 'Properties' option from the menu.

6. Click on the 'Options' tab and select the 'Suppress Printing' option.

7. Click 'OK' to save the 'Object Properties' settings.

When you run the report, the warning message text that you setup earlier appears against the 
balances that exceed £2500.

In the example, you can see that the Petty Cash account has a warning displayed as the current 
balance is only £163.88. The amount is also displayed as italics. If you have followed the 
example, the amounts in your report will also be displayed in a different colour.
8
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Adding Page Numbers

There are two types of page numbering in Sage Report Designer. If your report, layout or letter 
prints over more than one page, you may want your page numbering to display each page out 
of the total number of pages being printed. This is called batch page numbering. However, if 
you are printing letters that vary in number of pages, you may want your letters only to display 
each page out of the total number of pages for that letter alone.

To add a batch page number

1. In 'Design' mode, open the report, letter, label or layout that you want to add a batch page 
number to.

Note: If you want to add text to the page numbers, you may find it easier to select the 
'Active Complete' option on the Object Toolbar before proceeding with the next steps.

2. Select the 'REPORT' table from the 'Table' drop-down list, and then select the 
'BATCH_PAGE' variable. This displays the page number only.

3. Click the report layout at the position in the 'Header' or 'Footer' section where you want to 
insert the page number.

If you have chosen to use 'Active Complete', the 'Active Complete' window appears.

4. Select to enter text to the left of the variable, and type in a description. In this example the 
word 'Page' is suitable.

Click 'OK', and the text and variable appears on the report design.

5. If you want to display the page number out of the total number of pages, you also need to 
add the 'BATCH_PAGES' variable. In this instance you may add the word ''of'' to the left 
of the variable.

When you have finished, your report design layout should look like the following:
           

A preview of the reports, letters labels or layouts shows the consecutive numbering.
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6. Save your changes.

In the example above, the invoice layout uses batch numbering. There are 69 invoices to 
be printed, so the batch page numbering shows Page 1 of 69, Page 2 of 69 and so on, on 
each page.

To add a page number

1. In design mode, open the report, letter, label or layout that you want to add a page number 
to.

Select the 'REPORTS' table from the 'Table' drop-down list, and then select the 'PAGE' 
variable.

2. Follow the procedure for adding batch page numbers and at step 5, select the 'PAGES' 
variable.

3. Save your design.
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When you run the design to preview or print a number of copies of the document, the 
number of pages appears in the position you specified on the design screen.

The same invoice layout used in the previous batch page numbering example, is now set 
up using the PAGE/PAGES variables. Notice the difference in the following illustrations.

           

           

Although there are 69 invoices to be printed, there is only one page for each customer 
invoice. The first copy states ''Page 1 of 1'', and all subsequent copies state ''Page 1 of 
1''.
2
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Saving Reports

When you are finished creating or editing your report, you must save your changes. If you are 
editing a fixed report, you must save the report using a different file name so that the original 
report information remains unchanged.

You can also save your report as a different type of file output if required. For example, you can 
save the report as a Comma Separated File (*.csv) or as a Delimited File (*.csv) if you need to 
edit the output format before it is saved.

To save your report

1. To save the report using the same name, from the main toolbar, click the 'Save' option.

To save the report using a different name, from the 'File' menu, choose 'Save As'.

The 'Save As' window appears.
           

2. From the 'Save in' drop-down list, select the folder where you want to store the report.

It is good practice to store all reports of the same type in the same folder. For example, 
customer reports should be saved in the Customer folder. In Sage 200, this means that 
you could access the report from the Sales Ledger module, whereas in Sage 50, these 
reports would be accessed from the Customers module. For information about where the 
different types of reports are stored see The Report Designer File Structure section.

3. In the 'File name' box enter a name for the report. 

4. Click 'Save'.

The report is now saved.
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Saving reports as CSV files

The CSV file format enables you to import your report information into other products including 
other Sage programs, Spreadsheet products, BACS and third party company software, 
avoiding the need to duplicate work and enter values manually.

You can save your report as a CSV file from two different areas in the Report Designer; when 
running your report to preview from your Sage program Reports Windows, and also when 
working on the report in the Report Design or Preview mode.

To save your report as a CSV file

1. If you are running your report to preview from one of your Sage program's Report 
Windows, the report options are displayed below the report preview.

           

2. To save your report as a CSV file from this view, click 'Save As' below the report preview.

The 'Save As' window appears.

3. From the 'Save as type' drop-down list, select 'Comma Separated Files (*.csv)'.

4. Click 'Save'.

The report is now saved as a CSV file. When viewed, the CSV file shows all text variables 
enclosed within quotation marks, leaves numeric variables without enclosing quotation 
marks, and separates each field with a comma.

If you want to save your report as a CSV file and are in the Report Design or Preview mode, 
from the 'File' menu drop-down list, select 'Save As'. Follow steps 3 and 4 above, to 
complete saving your report as a CSV file.

Report option buttons
4



 Report Designer Basics
Saving reports as delimited files

The Delimited file output is essentially the same as CSV file format, but offers you more control 
about how the format is created. You can specify the file extension, separator, text and numeric 
qualifiers (','', and none for no qualifier), and fixed length applied to each variable.

For example, you may be using a third party company program that uses a slightly different CSV 
file format to the standard, requiring a full stop rather than a comma to separate fields. The 
delimited output, allows you to change the format to accommodate these differences.

You can save your report as a delimited file from two different areas of the Report Designer; 
when running your report to preview from your Sage program Reports Windows, and also when 
working on the report in the Report Design or Preview mode.

To save your report as a delimited file

1. If you are running your report to preview from one of your Sage program's Report 
Windows, the report options are displayed below the report preview.

2. To save your report as a Delimited file from this view, click 'Save As' below the report 
preview.

The 'Save As' window appears.

3. From the 'Save as type' drop-down list, select 'Delimited Files (*.csv)'.

The Options button appears at the bottom of the 'Save As' window.
           

4. Click 'Options'.

The 'Delimited Output Options' window appears.
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5. Select one of the following options as required:
          

6. Select from the following drop-down lists as required:

None Do not use a separator between each variable.

Space Use a space as a separator between each variable.

Tab Use a tab to provide the space between each variable.

Other Select this check box and enter any single character to act as 
the separator between each variable.
6
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7. Click 'OK'.

8. From the 'Save As' window, click 'Save'.

The report is saved with the delimited output settings you have chosen.

Note: If you want to save your report as a delimited file and are in the Report Design or 
Preview mode, from the 'File' menu drop-down list, select 'Save As'. Continue to follow 
the To save your report as a delimited file instructions from step 2 onwards.

Text Qualifier From the drop-down list, select the type of qualifier you want 
to use to enclose the text fields.

Numeric Qualifier From the drop-down list, select the type of qualifier you want 
to enclose the numeric fields.

Fixed Length Variables Select this check box, and the variable's length is set to the 
output length already defined in the Object Properties Pos/
Size tab.

If you clear the check box, the data length determines the field 
length.

Save as defaults for new 
reports

Select this check box, to make the completed settings 
become the standard settings for each new delimited output 
report you create.

These new settings will not be applied to any delimited output 
reports saved prior to the changes.
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Saving Reports as Text Files

The 'Text Files (*.txt)' format enables you to import your report information into other products 
including other Sage programs, Spreadsheet products, BACS and third party company 
software, eliminating the need to duplicate work and enter values manually. You can enable the 
Sage Report Designer to save your text files either in ANSI or OEM format, with the ANSI format 
as the default setting.

To save your report as a text file in ANSI or OEM format

1. Before you run your report to preview, from the 'Tools' menu select 'Options'.

The 'Options' window appears.
           

2. From the 'Text output' drop-down list, select 'Ansi' and click 'OK'.

3. Run the report you want to save as a text file to preview.

4. To save your report as a text file, click the 'Save As' option which is positioned below the 
report preview.

The 'Save As' window appears.

5. Enter a name for the report in the 'File name' box.

6. From the 'Save as type' drop-down list, select 'Text Files (*.txt)', and click 'Save'.
8
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Your report saves as a text file in ANSI format.

All subsequent reports you save as text files are saved in ANSI format. To change the 
format to OEM, follow steps 1 and 2 of this procedure, and select the OEM file output 
option.
 79



Sage Report Designer User’s Guide

8

The Report Designer File Structure

The Report Designer stores all report information in a main folder 'Reports'. Within the Reports 
folder there are a number of sub-folders which hold specific report and stationery layout 
information.

Sage 200 Accounts

The file structure for the reports and stationery layouts supplied with Sage 200 accounts is as 
follows:

          

You can also find the reports from the Commercials modules in the following directories:
          

Additional reports can be found here:
          

Type of Documents Filename Extension Directory

General (VAT Analysis) 
Reports

*.SRT SAGE\REPORTS\GENERAL

Sales Ledger Reports *.SRT SAGE\REPORTS\SALES

Purchase Ledger Reports *.SRT SAGE\REPORTS\PURCHASE

Cash Book Reports *.SRT SAGE\REPORTS\CASHBOOK

Nominal Reports *.SRT SAGE\REPORTS\NOMINAL

Layouts *.SLY SAGE\LAYOUTS

Letters *.SLT SAGE\LETTERS

POP *.SRT SAGE\REPORTS\POP

SOP *.SRT SAGE\REPORTS\SOP

Pricebook *.SRT SAGE\REPORTS\PRICEBOOK

Stock *.SRT SAGE\REPORTS\STOCK

BOM *.SRT SAGE\REPORTS\BOM

Traceability *.SRT SAGE\REPORTS\TRACEABILITY
0
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Sage 200 Manufacturing
          

Labour Categories *.report SAGE\REPORTS\CATEGORY

Certificates of Conformity *.report SAGE\REPORTS\CERT

Drawings *.report SAGE\REPORTS\DRAW

Employees *.report SAGE\REPORTS\EMPLOYEE

Estimates *.report SAGE\REPORTS\ESTIMATE

Expense Types *.report SAGE\REPORTS\EXPENSE

One-off Works Orders *.report SAGE\REPORTS\JOBS

Labour *.report SAGE\REPORTS\LABOUR

Machines *.report SAGE\REPORTS\MACHINE

Non Chargeable Time *.report SAGE\REPORTS\NONPROD

Operations *.report SAGE\REPORTS\OPERATION

Planning *.report SAGE\REPORTS\PLAN

Prospects *.report SAGE\REPORTS\PROSPECT

Sub Contract *.report SAGE\REPORTS\SUBCONTRACTING

Timesheets *.SRT SAGE\REPORTS\TIMESHEET

Works Orders *.report SAGE\REPORTS\WORKS

Project Accounting *.SRT SAGE\REPORTS\PROJECT
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Printing Reports

In the Report Designer main window you can switch between viewing the report layout and 
previewing the actual report details. You can print both the report layout and the actual report 
details.

If you are viewing the report layout and you click the 'Print' option from the main toolbar, the 
report layout is printed. The printout displays the section names slightly differently to the screen 
view; presenting them in a shaded bar, for ease of viewing. For further information about the 
various tables, criteria and sorts that have been placed into the report, from the 'Help' menu 
select 'Report Information'. You can then select the information types appearing on your report 
that you want further details about.

If you are previewing the report and click the 'Print' option from the main toolbar, the actual 
details of the report are printed (such as names, addresses and values).

To print your report

1. From the Status bar, click either the 'Design' tab or 'Preview' tab as required.

2. From the main toolbar, click the 'Print' option.

The 'Print' window appears.
           

3. In the boxes provided, enter your printing requirements.
          

Copies Enter the number of copies you require.

Print quality From the drop-down list, select the number of dots per inch 
(dpi) you require. The greater the dpi the higher the quality of 
output.
2
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4. To change the printer to be used to print the report, click 'Printer'. To amend the controls 
of your printer, click 'Setup'. For more information about selecting a different printer see 
the the Changing Your Printer Settings section in the Changing Your Default Report 
Settings chapter starting on page 106.

5. Click 'OK'.

The report is printed.

To preview your report

1. From the Status bar at the bottom of the main reports window, click the 'Preview' tab.

The report appears in Preview mode.

2. To return to the Report Designer design view, from the Status bar select the 'Design' tab.

Print options From the drop-down list, select how you want to print your 
report. The 'All' option uses true type fonts and is the slowest 
of the four options in this list. The quickest method of printing 
is to use the 'Quick Text' option which just uses the quickest 
font suitable for your printer.

Print to file Select this check box if you want to print your report to a file. 
A 'Print to File' window appears. You can specify which folder 
you want to save your file to, and enter a name for the report 
file.

Note: Your report saves as a windows *.prn file which cannot 
be re-opened within Sage Report Designer.

Collate copies If you are printing more than one copy of your report and want 
to print your first copy completely, before printing the first 
page of the second copy, select this check box. If you leave 
this check box clear, the Report Designer prints all the copies 
of page 1, then prints all the copies of page 2, and so on.

Print range Enter the print range you want to print, for example, Page 1 to 
Page 5.
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E-mailing Reports

Reports can be e-mailed to individuals or groups of people. You can e-mail reports when you 
are previewing them, and using the 'E-mail' option on your Reports window. E-mail 
attachments can also be stored and included with your Sage reports when sending. The Report 
Designer can be used to obtain e-mail addresses from your Sage data.

To use this feature, you must have a MAPI compatible e-mail program. Examples of MAPI 
compatible programs are Outlook 97 and Outlook 2000.

Note: Outlook Express is not MAPI compatible. If you are using an e-mail program that is not 
MAPI compliant, you are given an error message when sending the e-mail, and the e-mail fails 
to send.

You can use the Report Designer to enter the settings that should always be used for the report. 
You can specify:

Who you want to receive the e-mail

Whether the report is sent in plain text format or HTML format

What parts of the report should be sent

Whether the report is sent straight away or saved to your mailbox

Whether the report is to be sent with any other e-mail attachments.

Once you have saved your report's e-mail settings, you can e-mail the report whenever 
required.
4
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E-mail Settings

The E-mail Settings window is split into three main areas:

Who the report is going to be sent to, and how the e-mail is going to be identified in the 
recipient's Inbox

How the report is going to be formatted, to make it easy for the recipient to access the 
report

How you, the sender, decide to send the e-mail to ensure success first time.

The following instructions explain each of these stages to guide you though the e-mail process.

To set up your e-mail addresses

1. From the 'Format' menu, choose 'E-mail'.

The 'E-mail Settings' window appears.
           

2. Click 'To'.

The 'E-mail Addresses' window appears.
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3. In the 'Addresses' box, enter the individual addresses for the people you want to send the 
report to and click 'Add'.

The e-mail address appears in the list.

Note: If you make a mistake, select the e-mail address from the list and click 'Delete'.

4. In the Variables section, from the 'Table' drop-down list select the table that holds a 
variable containing e-mail addresses. From the 'Variables' drop-down list, select the 
variable that contains e-mail addresses and click 'Add'. 

Note: This variable is usually named 'E_MAIL'.

The table name followed by the variable name appears in the list. When you run the report, 
the report is e-mailed to all e-mail addresses contained in the variable.

For information about variables, see Adding Variables on page 19, earlier in this chapter.

5. Click 'OK' to save your address information.

The 'E-mail Settings' window reappears.

6. To enter addresses for people you want to send copies of the report to, click 'Cc'.

Repeat steps 3 to 5 to enter the second set of addresses.

7. To enter a description for the e-mail which identifies the e-mail when it arrives with the 
recipient, click 'Subject'.

The 'E-mail Subject' window appears.

If you have entered e-mail 
addresses within your Sage 
program, they are stored in 
the table that relates to the 
area they were entered in.

For example, if e-mail 
addresses were entered in a 
Customer record, they will 
be held in the SYSCompany 
table as EMAIL_ADDRESS.
6
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8. In the 'Subject Text' box, enter the text you want to use to describe the contents of your 
e-mail. To include a variable's value in the subject box, use the drop-down lists to select 
the variable you require and then click 'Insert into Subject'.

9. Click 'OK' to save your subject text.

The 'E-mail Settings' window is displayed again.

Selecting the formatting option for your e-mail report
You can choose to format your report in two different ways:
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          :

To enter the settings for sending your e-mail report

1. From the 'E-mail message should contain' drop-down list, select an option as follows:
          

Send the report as plain 
text

Select this option if you want the report to become the 
contents of the e-mail.

Note: The formatting or layout of the report can be 
significantly altered due to the design screen setting the 
length of the lines on the report/layout. The specified line 
length does not fit onto an e-mail and so the words on the 
lines are forced to wrap (move onto the lines below).

Send report in HTML 
(web page) format

Select this option to send your e-mail in HTML format. This 
differs to the above option, as the actual report/layout is 
attached to the e-mail as an HTML file rather than being part 
of the e-mail itself.

Note: The HTML format can then be viewed using an Internet 
browser such as Internet Explorer or Navigator. This also 
means that the formatting of the report/layout is kept due to 
automatic resizing.

The whole report Select this option to send the entire report to the e-mail 
addresses you have entered on the 'To' and 'Cc' tabs.

Group Select the group options to send only the information 
contained in the selected group section to the e-mail 
recipients.
Generally, you would use this option if you selected a variable 
that contains e-mail addresses on the E-mail Addresses 
window. When you choose this option, recipients only receive 
information that relates directly to them.

To use this option you need to have groups set up on your 
report and ensure the group has a page break so that each 
person's information is shown on a separate page. For 
information about groups see the Grouping Report 
Information section in the Advanced Features of the Report 
Designer chapter starting on page 114.

For information about adding page breaks to sections, see 
Sections on page 134.
8
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2. Select either of the options below as appropriate:
          

3. Click 'OK' to save your e-mail settings.

E-mail Attachments

When you e-mail Sage reports, you can add any type of attachment you require to your e-mail. 
For example, you may want a Sage report to be accompanied by other company reports. To 
do this, attach the company report(s) you require to the Sage report during the e-mail set up 
process. In our example, this would be accomplished by locating the company report file, 
selecting it, and confirming the procedure.

Note: If you attach a Sage *.SRT file to your e-mail, you are sending the report design rather 
than the report data.

To enter your e-mail attachment settings

1. With your report open in design view, from the 'Format' menu choose 'E-mail'.

The 'E-mail Settings' window appears.

2. To view the Attachment file(s) list, select the 'E-mail Attachments' tab.

Send e-mails 
automatically

All e-mails are automatically sent through your e-mail client, 
so you do not have to go into each individual e-mail and send. 
A copy of the e-mail is saved into your Sent Items folder.

Save e-mails to mailbox Each e-mail is saved into your Inbox for you to send later. This 
allows you to check the e-mails created by the system before 
sending them.
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3. To add the file(s) you want to attach to your e-mail report, click 'Add File(s)'.

The 'Add Attachment File(s)' window appears.

4. Select the file(s) that you want attached to your e-mail, and click 'Add'.

The file(s) is displayed in the 'Attached Files' box.

5. To remove a file from the Attached Files box, select the file and click 'Remove'.

A confirmation window appears.

6. Click 'OK' and the file disappears from the Attached Files box.

7. To change the order of the files in the Attached Files box, which controls their order on the 
e-mail, select the file to move, and use the 'Change Order' up or down buttons.

The file moves up or down the list.

8. Once the file(s) appears in the correct position in the Attached Files box, click 'OK'.

9. Save your report.

You have now completed entering and saving your e-mail attachments settings. When you 
e-mail your report, the attachments you have specified are included.
0
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Changing Your Default Report 
Settings
In this chapter:
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Changing Your Page Settings ..........103

Changing Your Printer Settings ........106

Changing Your Label Settings ..........108
This chapter includes information about 
changing the default settings for your 
report.

When you make a change to a default 
setting, the change is applied to the whole 
report. For example, if you changed the 
numeric settings to place a pound sign 
before each value, then all numeric 
variables placed on the report after the 
change was made will automatically have 
a pound sign. The numeric values already 
on the report will remain unchanged.

The default settings can be changed using 
the 'Options' option from the 'Tools' 
menu.



Remember....

....as well as changing the default settings for the objects on your report, you can change 
the properties of individual objects.

When you change the properties of an individual object, it overrides the default settings 
you have entered. You change an objects properties by double-clicking the object on the 
report layout and then making amendments in the Object Properties window.

For more information about changing the properties of individual objects see the 
Changing Object Properties section in the Report Designer Basics chapter.

Changes to your default settings only affect objects added to the report after the changes 
were made. Objects that already existed on your report will remain unchanged.



 Changing Your Default Report Settings
Changing Your Grid Settings, Measurement Units and Other 
General Options

You can use the settings available on the 'Options' tab to set up your measurement units, your 
.txt file format and other general options, such as sticky buttons and the way that you sort your 
variable lists.

Grid lines are invisible lines used to align the objects on your report. You can set the distance 
between the grid lines to any width and height you require. When the 'Snap to grid' option is 
selected, any new objects entered, automatically align themselves to the nearest horizontal and 
vertical grid position.

The Report Designer works in centimetres or inches. You can change the units used at any time 
and the measurements already in use will be converted automatically.

To change your default general options

1. From the 'Tools' menu, choose 'Options'.

The 'Options' window appears.
           

2. In the 'Grid Settings' section, enter your grid position requirements as follows:
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3. In the 'General' section, enter your document options as follows:
          

Snap to grid Select this check box to activate the grid. When the 'Snap to 
grid' check box is selected, any new object entered, 
automatically aligns itself to the nearest horizontal and vertical 
grid position.

Horizontal setting Enter the horizontal spacing you require between the grid 
positions. If necessary, use the up or down buttons to 
increase or decrease the values shown.

Vertical setting Enter the vertical spacing you require between the grid 
positions. If necessary, use the up or down buttons to 
increase or decrease the values shown.

Sticky Buttons If you select this check box, the cursor remains in the selected 
mode until you change it.

For example, if this check box is selected, after you insert text 
the cursor remains in text mode until you select the 'Select' 
mode.

Sort variable
lists

Select this check box to order the variable lists within Report 
designer alphabetically.

Use active
complete

Select this check box if you want to automatically add titles 
and/or totals for variables when you add them to your report.

Show object
tooltips

Select this check box to view information about objects when 
the cursor is moved over them.

Show section
names left of
page

Select this check box to show the section names and 
extended section line at the left of your report layout.

To view further details about the section, from the object 
toolbar select tooltips. Move the cursor over the section name 
and additional information is displayed about the section.

Clear the check box to show the section names on the report 
layout.

Note: These names are never printed on the final report print 
out.
4
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4. In the 'Font change settings' section, enter your requirements as follows:
          

5. To save your settings, click 'OK'.

Measurement From the drop-down list, select either 'Centimetres' or 
'Inches'. You can change the units used at any time and the 
measurements already in use will be converted automatically.

Text output You can choose to save your CSV, Delimited or TXT output 
files, as ANSI (Windows format) or OEM (DOS format). From 
the drop-down list select which file format you require. When 
you next save one of the file types detailed above, it will use 
the ANSI or OEM format you have specified.

Show dialog on
font change

Select this check box to always display a prompt when 
changing a font property of an object. The prompt asks 
whether to apply the changes to the style or just to the object 
selected.

If the check box is not selected, the following two options 
become enabled:

Always update styles on 
font change

Select this option so that if one object is selected and its style 
is altered, the changes affect all objects using that style 
without giving a prompt.

Never update styles on 
font change

Select this option, so that if one object is selected and its style 
is altered, the changes only affect that object, without giving a 
prompt. The object's style is set to 'None', disassociating it 
with its original style.
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Changing Your Document Settings

The Report Designer helps you to place objects so that they appear in the correct boxes on 
your pre-printed stationery by providing you with a special image of the Sage stationery you are 
working on. These are stored in separate files called template files and you can load one at any 
time. The layout template files are never actually printed, they are for your guidance only. You 
can also amend the description of your report using the Document tab.

If you are using Sage 200, the Criteria Help File facility is an additional feature available on the 
'Document' tab for you to use. It can only function with Sage 200, although you may still see 
the additional details on the 'Document' tab if you are using other Sage programs. When you 
run a report, it enables you to specify a topic in a Help file and set that topic to appear if you 
press F1 from the 'Criteria' window. You can use this feature to show help that describes the 
purpose of the report and the criteria displayed for the report.

To change your default document settings

1. From the 'Tools' menu, choose 'Options'.

The 'Options' window appears.

2. Click the 'Document' tab.

The Document information appears.
           

3. To load a template, select the 'Use template' check box, then enter the name of the 
template you require in the 'Filename' box. To find the template on your system, click the 
'Browse' button.

Note: All template files are saved in the \TEMPLATE folder within the appropriate Sage 
program directory. For example, if you are using Sage 200, the templates would be stored 
6
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in C:\SAGE\TEMPLATES. If you are using Sage Payroll, the templates would be stored in 
C:\PROGRAM FILES\SAGE PAYROLL\TEMPLATE.

4. In the 'Description' box, enter or amend the description for your report.

5. To save your settings, click 'OK'.

To set up the Criteria Help File (Sage 200 only)
If you are a developer and create your own help systems for the 'Criteria' area so that you can 
create a link to it. Once it has been set up, your help system will be called up when you press 
the F1 key on the 'Criteria' window.

1. From the 'Tools' menu, choose 'Options'.

The Options window appears.

2. Click the 'Document' tab.

The 'Document' tab information appears showing the 'Criteria help file' section.
           

3. Select the 'Use help file' check box, to activate the help.

4. Enter the path to the Help file in the 'Help file' box or locate it using the 'Browse' option. 
You can select a Windows Help file (*.hlp) or an HTML Help file (*.chm).

5. Enter the identification number for the appropriate Help topic (which is contained within the 
Help file), in the 'Topic ID' box, and click 'OK'.

6. When you next run the report and need help with Criteria in Sage Report Designer, click 
'Help' or press F1. The Help topic from the Help file you specified appears.
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Changing Your Numeric Settings

Use the 'Numeric' tab to set up the numeric defaults for your report. You can change the 
currency symbol which the Report Designer uses, set which numeric format to use, and you 
can set the Report Designer to suppress all items which are equal to zero.

To change your default numeric settings

1. From the 'Tools' menu, choose 'Options'.

The 'Options' window appears.

2. Click the 'Numeric' tab.

The Numeric information is displayed.
           

3. Use the options on the 'Numeric' tab to set up your default numeric settings as follows:
          

Suppress if zero Select this check box if you do not want to print a value of 
zero on your report.

Note: If you select this check box, the Report Designer still 
prints the line of the report, but does not print a zero.
8
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4. To save your numeric settings, click 'OK'.

Note: The settings affect all objects added after the numeric settings are saved.

Fixed currency
symbol

Select this check box if you want the currency symbol entered 
in the 'Currency symbol' box to be in a fixed position on your 
report.

Display leading zero From the drop-down list, select either to show a decimal on 
your report with the leading zero or without (either as 0.111 or 
.111).

Numeric format From the drop-down list, select the numeric format you 
require for your report.

Thousands symbol Enter the symbol you want to use to separate thousands on 
your report.

Negative
symbol

Enter the symbol you want to use for your negative amounts.

Decimal symbol Enter the decimal symbol you want to use for your numeric 
values.

Currency symbol Enter the currency symbol you want to use for your numeric 
values.
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Changing Your Date Settings

Use the 'Date' tab to set up the default format you require for the Date variables on your report.

To change your default

1. From the 'Tools' menu, choose 'Options'.

The 'Options' window appears.

2. Click the 'Date' tab.

The Date information appears.
           

3. Use the options on the 'Date' tab to set up your default date settings as follows:
          

4. To save your date settings, click 'OK'.

The settings affect all objects added after the numeric settings are saved.

Date format From the drop-down list, select the date format you require.

Date separator Enter the character you want to use to separate both the date 
from the month, and the month from the year when using a 
short date format. For example, you could use / or a hyphen.
00
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Changing Your Time Settings

Use the 'Time' tab to set up the default format you require for the Time variables on your report.

To change your default time settings

1. From the 'Tools' menu, choose 'Options'.

The 'Options' window appears.

2. Click the 'Time' tab.

The Time information appears.
           

3. Use the options on the 'Time' tab to set up your default time settings as follows:
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4. To save your time settings, click 'OK'.

Note: The settings affect all objects added after the numeric settings are saved.

Use 24 hour
clock

Select this check box if you want to use the 24 hour clock 
format.

Apply zeros to
time

Select this check box if you want all time variables to consist 
of six digits, for example, if the time was 9.30am this would 
appear as 09.30.00.

AM Enter how you would like AM to appear on your report. For 
example, AM or am.

PM Enter how you would like PM to appear on your report. For 
example, PM or pm.

Time separator Enter the character you want to use to separate the hours 
from the minutes. For example, you could use a colon or a full 
stop.
02
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Changing Your Page Settings

The Report Designer obtains the default page size and margin information from the printer you 
have specified to print the report. In many cases, you should simply accept these automatic 
page settings. However, if you need to you can enter your own specific size and set the margins 
to how you want them.

To change your default page settings

1. From the 'File' menu, choose 'Page Setup'.

The 'Page Setup' window appears, showing the Margins information.
           

2. In the 'Margins' section, enter your margin settings.

To change the margins on each side of the report, click the appropriate up or down button. 
Alternatively, you can type the margins you require directly into the boxes.

Your altered margin settings will affect the position of the objects on the design view.

Note: You can also change your margins using the mouse, while viewing the report layout. 
Move the mouse pointer onto the ruler where the margin starts. A two-way arrow appears. 
Click and hold down the mouse button and drag the margin into a new position, then 
release the button.
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3. In the 'Print adjustment' section, enter any horizontal or vertical adjustments that the 
Report Designer should use when printing the report layout. You would use these options 
to print all of your report information further to the left or down the page.

Your print adjustment amendments do not alter the position of the objects on the design 
view.

4. The 'Print Scaling' section gives you the ability to increase or decrease the scale of your 
report horizontally and vertically when you print it out.

For example, you may find this particularly useful if you want a report to fit to a particular 
paper size you are using, or if you are using pre-printed stationery and need to make small 
amendments in combination with print adjustments to make the items fit in the boxes 
properly.

The report's standard size is 100%. To decrease the scale, use the down spinner arrow to 
decrease the percentage. To increase the scale, use the up spinner arrow.

Note: For more information on Print Scaling and using it effectively with Print Adjustments 
search the Report Designer Help for printing:adjustments and scaling.

5. Click the 'Size' tab to adjust the following:
          

6. Click the 'Source' tab to select which of your printers' paper trays to use. The list shown 
on the 'Source' tab is appropriate for the printer you selected using the 'Print Setup' option 
(see the following Changing Your Printer Settings section).

Paper size From the drop-down list, select the paper size that matches 
your stationery. The list shown is appropriate for the printer 
you selected using the 'Print Setup' option (see the following 
section Changing Your Printer Settings), although you can 
adjust the paper size using the boxes below.

If you are using a template and have changed the paper size, 
the paper size reverts back to the template's default when 
you save the layout.

Paper width If your paper size is set to 'User Defined' you may need to 
enter the width of your paper. In all other cases the paper 
width will revert to the paper size settings.

Paper height If your paper size is set to 'User Defined' you may need to 
enter the height of your paper. In all other cases the paper 
height will revert to the paper size settings.

Paper orientation Select whether the short side of the paper is the top of the 
page (portrait) or the long side of the paper is the top of the 
page (landscape).
04



 Changing Your Default Report Settings
7. To save your page settings, click 'OK'.

The page settings are saved ensuring that you do not have to edit the settings each time 
you want to print the report.

Note: If your report's layout cannot be edited, you must save the report using a different 
filename. For more information, see the Report Designer Basics section in the Report 
Designer Basics chapter.

If you are using Sage 200, and want to launch a report saved with a different filename from 
the tree menu, you can edit the tree menu to include the amended report. For more 
information, refer to your Sage 200 product documentation.
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Changing Your Printer Settings

You can change the printer used to print your report, and the default printer fonts.

When you select a printer, the Report Designer checks which fonts are available and sets the 
margins. The paper size will also be automatically set for you from the default size that was set 
up for the printer when you installed the printer into Windows. When you save your report, the 
information about what printer has been selected is also saved. This means that when you print 
the report it will always use the printer you specified.

The 'Printer' tab automatically shows the default fonts for your default printer. If your printer has 
been set up correctly you should not normally need to amend them.

To set the default printer

1. From the 'File' menu, choose 'Printer Setup'.

The 'Printer Setup' window appears.

2. From the list of printers, select the printer you want to use to print the report.

This list is made up of those printers already installed to work with Windows. If you want 
to add a new printer, use the Windows Control Panel (see your Microsoft Windows Help 
system).

3. Click 'OK'.

The Report Designer now builds the font list for the printer you selected and sets the 
margins.

Whenever you print your report the printer you selected will be used by default.

Note: The fonts and margins available in the Report Designer vary depending upon the 
printer driver loaded. Therefore, if you change your printer, you may need to adjust your 
report layout accordingly.

To change your default printer fonts

1. From the 'Tools' menu, choose 'Options'.

The 'Options' window appears.

2. Click the 'Printer' tab.

The Printer information appears.
06
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3. Select which font you want to change, either the 'Default' or the 'Quick Print' font, then 
click the 'Modify' button.

The 'Style Font' window appears.

4. Amend the font as required and click 'OK'.

Note: We recommend that when modifying the Quick Print font, you choose a 'Printer' font 
(identified by a small printer icon beside it) rather than a 'True Type' font. This ensures 
faster printing when you select 'Quick Text'.

5. To return to the Report Designer window, click 'OK'.
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Changing Your Label Settings

You can amend the settings of the labels that are available within the Sage 50 and Instant 
Accounts Plus Report Designer. For example, you could change the number of labels required 
for the width of the page.

To change your label settings

1. From the 'File' menu, choose 'Page Setup'.

The 'Page Setup' window appears.
           

2. From the 'Printer type' drop-down list, select the type of printer you want to use to print 
your labels.

3. From the 'Label Type' list, select the label type that matches the stationery you want to 
print your labels on.

4. To modify a label type's settings, select the label type and click 'Modify'.

The 'Label Options' window appears.

5. In the boxes provided enter the margins, the width and height of the labels, and number 
of labels you want to appear on a page.

6. Click 'OK'.

The 'Page Setup' window reappears.

7. To save your label settings, click 'OK'.
08
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The Report Designer's flexibility lets you 
be very selective about the information 
you want to include on your reports and 
how you want to show it.

This chapter includes information about 
how to use the more advanced features 
available to you when using the Report 
Designer.



Remember...

... the Example Reports chapter includes instructions about how to create a number of 
different reports using the features described in this chapter and the Report Designer 
Basics chapter.

The examples in the Example Reports chapter cover the following topics:

Using the Report Wizard

Creating reports manually

Using sorts

Using groups

Using criteria

Using expressions

Using filters

Removing sections to produce a summary report.
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Sorting Report Information

You can arrange the information on your report in a specific order by adding a sort to your 
report. Sorts enable you to get the most out of a report simply by re-ordering your report 
information. For example, the report below shows the balances sorted by the Customer's 
'Account Reference'.

           

You may prefer to see the Customer's Balance information sorted by the Balance Value in 
descending order, to more easily identify particular customers that you need to contact. This 
requires removing the Account Reference Sort and adding a sort on the 'Balance' column.
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For more information about creating a Customer Balance report, see the Creating a Customer 
Balances Report (Sage 50 and Instant Accounts Plus) section in the Creating Example Reports 
chapter.

The three key points to remember about Sorts...
A sort can be applied to any variable that is present on your report.

For example, you could set up a sort for the 'Date' variable, so that the items on your report 
print in chronological order rather than the order in which the transactions were entered in 
your Sage program, or with the oldest transaction first.

A sort is automatically added by a group and can be applied to any groups you have set 
up on your report. You can also add as many sorts as you want to a report.

A sort can be either be in ascending or descending alphanumeric order.

For example you can use the 'Sort' option to list variables in ascending order (A-Z) or 
descending (Z-A), or you can sort on a numeric variable, which means you can sort in 
ascending (lowest-highest value), or descending (highest to lowest value).

To sort information on your report

1. From the 'Format' menu, choose 'Sorts'.

The 'Sorts' window appears.
           

Note: If you have set up any groups, the group variables will appear in this window 
automatically.

2. Click 'Add'.

The 'Add Sort' window appears showing all the variables in your report.
12
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3. Select the variable you want to sort by from the list.

4. You can sort in ascending or descending order. Select the option you require.

Note: Numbers are sorted before letters in ascending order, so 01ABLE would be listed 
before ABLE01.

Note: The sort ignores the case of a character, for example, 'A' is the same as 'a'.

5. To save your sort, click 'OK'.

The Sorts window reappears.

6. To return to the Report Designer window, click 'Close'.

To delete a sort from your report

1. From the 'Format' menu, choose 'Sorts'.

The 'Sorts' window appears.

2. Select the sort you want to remove and click 'Remove'.

3. To return to the Report Designer window, click 'Close'.

The list displays the 
variables that have been 
added to the report. The list 
will change depending on 
the report you are viewing.
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Grouping Report Information

When you create a report, you may want to list all the items relating to one variable together. 
You can list these items by creating a group. For example, you could set up your report to show 
all the items for one sales account reference together. Alternatively, you could list together all 
transactions with the same date.

A simple report consists of the following three basic sections:

Page Header

Details

Page Footer.

When you add a group to your report, the Report Designer automatically creates a header and 
footer section for the group in your report layout. For example, if you added a group to list all 
the items which have the same account reference together, the sections on your report would 
change to:

Page Header

Account_Ref Header

Details

Account_Ref Footer

Page Footer.

If you add another group to the report using the same variable, so for example, you now want 
to have a second group using the Account Reference variable, the section names are appended 
with a 2 as follows:

Page Header

Account_Ref header

Account_Ref header 2

Details

Account_Ref footer

Account_Ref footer  2

Page Footer.

Once you have set up a group, you may want to arrange the variables within that group in either 
an ascending or descending order (see the Sorting Report Information section).

You can set up your group to keep together all the items relating to the group on the same page 
of the report. If there are too many entries to fit onto one page, the Report Designer puts as 
many as it can on one page and continues on the next.
14
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You can set up as many groups as you like on a report, and can create a group for a variable 
which does not even appear in the report. For example, if your report shows the sales account 
reference and net amount, you could organise your report to show the net amounts in date 
order.

When you preview a report in Sage 200 that contains a preset group, you can choose to 
override this group and select another variable from the same table to group by.

You can remove a group from your report at any time. However, if you delete a group, you also 
remove a sort for it. The group header and footer sections are also removed, which also 
includes the removal of any variables contained within the group header or footer.

Preparing to create a group
The first steps to creating a group relate to understanding what information it is that you 
are trying to get from your report.

You need to group by common elements on a report, so it is best to look at or imagine 
your list of data, and consider what the common elements are that would be most useful 
grouped together.

           

In the example above, the common element that will give meaning to the report, if grouped, 
is the Department Reference. This makes the report more useful, enabling the report to 
more clearly display the employees in each department.

Once the purpose of the report is determined, and the common element(s) identified, you 
can locate the Department Reference variable on the Design view, and add a group.
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To group information on your report

1. From the 'Format' menu, choose 'Groups'.

The 'Groups' window appears.
           

2. To set up a new group on your report, click 'Add'.

The 'Add Group' window appears.
           

3. From the 'Table' drop-down list, select the table you require.

The 'Variables' list displays the variables for the table you selected.

4. Select the variable you want to group by, and click 'OK'.

The 'Groups' window reappears, and an additional 'Header' and 'Footer' are created on 
the report design.

The example shown 
is for Sage Payroll/
Payroll Professional 
only. The tables and 
variables available on 
this window will 
change depending 
on the program you 
are using.
16
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You are now ready to set up the details for the group.

To set up the details for a group

1. From the 'Format' menu, choose 'Groups'.

The 'Groups' window appears.

2. Select the group you want to set up the details for and click 'Modify'.

The 'Group Options' window appears.
          

3. In the boxes provided, enter the following details:

Reference Header and 
Reference Footer 
sections created when a 
group is applied to a 
Department Reference 
variable.
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4. To save the details for the group, click 'OK'.

Your report is organised by the group you have applied.

For example, if we grouped the Employee Report discussed in the Preparing to create a 
group section, by the Department Reference, the report would look similar to the following.

Keep together Select this check box if you want to keep together all 
transactions/items relating to this group on the same page of 
the report.

Note: If there are too many entries to fit onto one page, the 
Report Designer puts as many as it can onto one page then 
continues on the next.

Include blank
transactions

Select this check box if you want to include all transactions in 
the group, even if they are blank.

Break after character
change

Select this check box to create a break in your report only 
when it sees a change in the variable within the first 'n' 
characters of the data, where 'n' is the number you enter in 
the 'Character count' box.

For example, if you have selected sales account references:

Jones

Joney

Jonne.

If you then create a character break and the character count 
is set to 4, your list would print as:

Jones

Joney

Jonne.

In this example, a break only occurred when the fourth 
character was different. The Report Designer ignored any 
changes occurring after the fourth character.

Note: If the change had been on the third letter, no break 
would have been given.

Character count Enter the number of characters of a variable that the Report 
Designer should check to see if a change has occurred. This 
number is only used when the 'Break after character change' 
check box is selected.
18
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To make the report look tidier, the Department Reference and Department Name variables 
have been moved from the Details section of the report design into the additional 
Reference Header created by the Group.

This means that the Department Reference and Name only appear once per set of 
employees, rather than for each employee.

To delete a group

1. From 'Format' menu, choose 'Groups'.

The 'Groups' window appears.

2. Select the group you want to delete and click 'Delete'.

A confirmation message appears.

3. To delete the group, click 'Yes'.

When you delete the group, the Report Designer automatically deletes the header and 
footer sections of the report layout that were created for that group and any variables held 
in these sections.
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To override a group in Sage 200

1. From the 'Format' menu, choose 'Criteria'.

The 'Criteria' window appears.

2. Select the 'Group Sort Override' status box, and from the drop-down list, select 'Enabled', 
and click 'OK'.

Note: To set up your own preset group sort override, follow the instructions to override a 
group, selecting Preset from the drop-down list in step 2.

3. From the 'Group Sort Override Status' box, select the variable that you want to sort the 
report by, and then select whether the sort is to be ascending or descending. It will default 
to ascending.

4. Click 'OK'.

The report previews and prompts you to use the group sort override.

If you select Preset in Step 2, the report previews using the group sort override 
automatically without prompting you.

Note: To activate 'Group Sort Override' for a group, the group must appear in your report 
design view in the outermost report table. This is preset for each report type. You can view 
it more easily by selecting 'Groups' from the 'Format' menu. The outermost table is the first 
table description shown in the 'Groups' column.

To remove a group sort override
Select the 'Group Sort Override Status' box, and from the drop-down list, select 
'Disabled'.

The report applies the original group sort.
20
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Setting Criteria

If you do not set up criteria for your report, then the report generated includes every record that 
exists in the data file that it reads. Use the 'Criteria' option to be more selective about the 
information you print.

For each report you create, you can set up a pre-set criteria so that each time you run the report 
it uses the same criteria. For example, you may always want to run the same report for 
customers with an account reference between A001 to A999.

Alternatively, you can enable the criteria, so that each time you run the report a Criteria window 
appears asking you to enter the criteria you require. Sage 200 also enables you to save and 
load criteria settings. For more information about Saving and Loading, see the Prepare Reports 
Chapter in the Sage 200 Operations Guide.

Note: Any criteria you set up is saved for that report only.

To set up criteria for your report

1. From the 'Format' menu, choose 'Criteria'.

The 'Criteria' window appears. By default, all criteria is disabled (turned off).
           

2. Set the status you require for each variable as follows:

The variables displayed 
will change depending 
on the Sage program 
you are using.
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3. To accept your criteria, click 'OK'.

4. If you have set some variables to have the status of 'Preset', the 'Criteria window' appears 
for you to set your criteria.

Enter the variable ranges which you want the Report Designer to use automatically for this 
report, then click 'OK'.

Disabled Select this option if you do not want to set any criteria range 
for the variable when the report is run.

Enabled Select this option if you want the Report Designer to ask you 
to enter a criteria range for the variable every time you run this 
report.

The default range is for the full range of the variable. For 
example if you choose the 'AccountNumber' variable in Sage 
200, the default range would be the first and last account. 
You can change this range if required every time you run the 
report.

Preset Select this option if you always want to use the same criteria 
range every time you run this report.

When you first apply the criteria you are asked to enter a 
range. This is the range that will always be applied to the 
report. You are not asked to confirm or amend this range 
when you run the report. If you want to amend the range, 
from the 'Format' menu, select 'Criteria', and click 'OK'.
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Adding Filters

Use the Report Designer's Filters option if you want to be more selective about the records or 
transactions you want to include in your reports. This is similar to criteria except that it embeds 
the selection into the report. The selection will always be used for the report. You are not given 
the choice of selecting the records you want to display when you run your report.

If you want the information included on your report to meet more than one condition then you 
can either connect your filters together or set up section filters. These filter statements can then 
be shortened if you require, and you can also use wildcards in your filter statements to search 
for information to include or exclude on your reports.

To set up a filter

1. From the 'Format' menu, choose 'Filter'.

The 'Filter' window appears.

2. Click 'Build'.

The 'Filter Builder' window appears.
           

3. Use the variables from each table and the operand buttons in the 'Filter' area to create the 
filter you require. To use a variable in the filter calculation, double-click the variable name, 
or select the variable and click 'Add'.

The operand buttons have the following meanings:

When a variable has been selected, 
the name of the table the variable 
comes from followed by the variable 
name is displayed.

Select the 'Show values' check box, to 
display the values in your database for the 
selected variable in the 'Values in 
Database' list. Warning: If you have a 
large database it may take a few minutes 
to load the values.

The variables available in 
the 'Variables' list will 
change depending on 
the table you have 
selected.
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> Greater than. Use this for Alpha, Numeric or Date fields where 
the field value required is higher than the filter value.

For example, for Sage 50, to include customers with a 
turnover for the year to date which is greater than £1000, 
select from the list of variables and use the buttons, to enter 
the following:

'SALES_LEDGER'.'TURNOVER_YTD' > 1000

For Sage Payroll, to include all employees whose Net Pay is 
more than £800, enter the following:

'sgtbl_EmployeePay_Values'.'NetPay1' > 800

For Sage Job Costing, to include jobs with a quoted value 
which is greater than £1500, enter the following:

'tblJob'.'Value' > 1500

< Less than. Use this for Alpha, Numeric or Date fields where 
the field value required is lower than the filter value.

For example, for Sage 50, to include customers with a 
turnover for the year to date which is less than £1000, enter 
the following:

'SALES_LEDGER'.'TURNOVER_YTD' <1000

>= Greater than or equal to. Use this for Alpha, Numeric or Date 
fields where the field value required is the same as or higher 
than the filter value.

For example, for Sage 50, to include customers with a 
turnover for the year to date which is greater than or equal to 
£1000, enter the following:

'SALES_LEDGER'.'TURNOVER_YTD' >= 1000

<= Less than or equal to. Use this for Alpha, Numeric or Date 
fields where the field value required is the same as or lower 
than the filter value.

For example, for Sage 50, to include customers with a 
turnover for the year to date which is greater than or equal to 
£1000, enter the following:

'SALES_LEDGER'.'TURNOVER_YTD' <= 1000
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= Equals. Use this for Alpha, Numeric or Date fields where the 
whole field is equal to the filter value.

For example, for Sage 50, to include customers with a 
turnover for the year to date which is equal to £1000, enter 
the following:

'SALES_LEDGER'.'TURNOVER_YTD' = 1000

<> Not equal to. Use this for Alpha, Numeric or Date fields where 
the whole field is not equal to the filter value.

For example, for Sage 50, to include customers with a 
turnover which is not equal to £1000, enter the following:

'SALES_LEDGER'.'TURNOVER_YTD' <> 1000

(  ) Use these brackets if you want to enter more than one set of 
conditions in your filter, but want the Report Designer to use 
the condition within the brackets first. 

For example, for Sage 50, to display all Sales Invoices and 
Sales Credits on any account where the current balance is > 
£1000, enter the following:

(AUDIT_SPLIT>TYPE=SI OR
AUDIT_SPLIT.TYPE=SC) AND 
SALES_LEDGER.BALANCE>1000

And The AND statement can be used to used to link variables that 
are alike or different. All values need to be matched in order 
for them to be picked up by the filter.

For example, for Sage 50, to include customers with both a 
turnover for the year to date which is less than £1000 and 
with a prior year balance which is greater than £2500, enter 
the following:

'SALES_LEDGER'.'TURNOVER_YTD' < 1000
AND 'SALES_LEDGER'.'PRIOR_YEAR' > 2500
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Tip: Select a variable from the list then select the 'Show values' check box to show the 
current values in your database for that variable in the 'Values in Database' list.

4. To save your filter, click 'OK'.

The 'Filter' window is displayed again.

5. To return to the Report Designer window, click 'OK'.

Or The OR statement is used as a link between variables that are 
alike, where the information in the field cannot be more than 
one thing at the same time. Either value needs to be matched 
in order for the filter to pick it up.

For example, for Sage 50, to include customers with either a 
turnover for the year to date which is less than £1000, or with 
a prior year balance which is greater than £2500, enter the 
following:

'SALES_LEDGER'.'TURNOVER_YTD' < 1000 OR 
'SALES_LEDGER'.'PRIOR_YEAR' > 2500

Not The NOT statement is used to reverse the operand directly 
following it and impose a limit on the variable you are filtering 
on.

For example, for Sage 50, you can use this button if you do not 
want to include customers with a turnover greater than £1000, 
enter the following:

'SALES_LEDGER'.'TURNOVER_YTD' NOT > 1000

Like This operator is most effectively used where Wildcards are 
necessary. For more information about Wildcards see the 
Using Wildcards section later in this chapter.

For example, for Sage 50, if you only want to include 
transactions for customer ABC, enter the following:

'SALES_LEDGER'.'ACCOUNT_REF' LIKE ABC

Clear Use this button to clear the filter area so you can start to 
create your filter again.
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Section Filters

Section filters work in exactly the same way as standard filters, but they are set up on the 
individual sections of your report. For example, you could set up a filter to show only accounts 
with balances in credit in one section, and only accounts with balances in debit in another 
section. You could then specify which section is printed when you come to run your report, 
depending on whether you wanted to see your creditors or debtors information.

Note: Functions are currently only available in Sage 200. For more information about the 
function types and how you can use these, please refer to the Report Designer online Help.

To set up a section filter

1. From the 'Format' menu, choose 'Sections'.

The 'Sections' window appears.

2. Select the section you want to add your filter to and click 'Modify'.

The 'Section Options' window appears.

3. From the 'Print' drop-down list, choose whether the section is printed by selecting 'If filter 
true' or 'If filter false'.

4. Click the 'Filter' tab.

The 'Filter' tab information is displayed.

5. Click 'Build'.

The 'Filter Builder' window appears.

6. Use the variables from each table and the operand buttons in the 'Filter' area to create the 
filter you require. For information about the meanings of the operands available, see step 
3 of the procedure, To set up a filter on page 123.

7. To save your section filter, click 'OK'.

The Sections window reappears.

8. To return to the Report Designer window, click 'Close'.
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Shortening Large Filters

Filter statements which are connected together using the 'OR' operand button can become 
quite large, and you may find them difficult to read. You can shorten these filters using the 'IN' 
operator without altering the condition.

For example, for Sage 50, if you want to include all payment and receipt transaction types from 
the Audit Trail on your report, using the Or operand would be:

'AUDIT_HEADER'.'TYPE' LIKE 'SR' OR 'AUDIT_HEADER'.'TYPE' LIKE 'SA' OR 
'AUDIT_HEADER'.'TYPE' LIKE 'PP' OR 'AUDIT_HEADER'.'TYPE' LIKE 'PA' OR 
'AUDIT_HEADER'.'TYPE' LIKE 'BR' OR 'AUDIT_HEADER'.'TYPE' LIKE 'BP'

Using the 'IN' operator the same filter statement would be:

'AUDIT_HEADER'.'TYPE' IN ('SR', 'SA', 'PP', 'PA', 'BR', 'BP')

Using Wildcards

In addition to the operand buttons in the Filter Builder window, wildcard searches can be used 
in your filter statements. Wildcard searches enable you to filter on only part of the information 
held in a field.

          

For example, for Sage 50, using the multiple character wildcard % to include all customers 
starting with the letter A on your report type:

'SALES_LEDGER'.'ACCOUNT_REF' LIKE A%

or, using the single character wildcard _ to include all sales ledger transaction types, for 
example, for SI, SC, SR and SA, type:

'AUDIT_SPLIT'.'TYPE' LIKE S_

Wildcard Description

% Multiple (string of) characters

_ Single character
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Creating Expressions

When you set up a report, you are given a list of tables and variables from which to select. 
However, if you want the report to show a value that is not immediately available to you as a 
variable on a drop-down list, you can derive this from a calculation involving other existing 
variables and functions. When a value is derived by a calculation involving other variables and 
functions it is called an 'Expression'.

For example, in Sage Payroll you might have a report that shows an employee's Pension To 
Date, and AVC To Date, but you also want the report to calculate the Total Pension To Date per 
employee, which is a sum of the two variables.

The variable tables do not immediately provide you with this information. So you need to create 
an expression which adds the two variables together and displays the total value per employee. 
In the following example, a report for Employee Pension Contributions has already been 
created.

To create an expression

1. From the 'Object' toolbar, click the 'Expression' option.

2. Click the cursor on the report layout at the point you want to insert the expression.

3. To set up your expression, double-click the expression.

The 'Object Properties' window appears.
           

4. In the 'Name' box, enter a name for this expression. In this example, you might enter 'Tot 
EE Pens Cont'.
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Note: Two expressions cannot have the same name.

5. Click 'Build'.

The Expression Builder window appears.
           

6. Use the variables from each table and the buttons provided to create the expression you 
require. To use a variable in the expression, double-click the variable name, or select the 
variable and click 'Add'.

For example, from the tables list choose 'sgtbl_EmployeeCumulative', then from the 
variables list choose 'EmployeeTD'.

Note for Sage 200 users: Variables added to the Expression Builder will be enclosed in 
straight brackets. For example, the variable for the Account Code in the cash book 
account table is displayed as [CBAccount].[AccountCode].

A formulae for the calculation is made up from one or more of the following arithmetic 
symbols:

          

+ For addition.

- For subtraction.

* For multiplication.

/ For division.

( ) Use brackets for grouping and prioritising calculations.

The tables and 
variables displayed 
will change 
depending on the 
Sage program that 
you are using.

When a variable 
has been selected, 
the name of the 
table the variable 
comes from, 
followed by the 
variable name, is 
displayed here.
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You can also include any numeric variables that currently exist in the report variable list, 
and any number (including decimals). If you use decimals, you should enclose the whole 
number using quotation marks. For example, '100.00'.

7. Continuing with the current example, click the '+' symbol.

The '+' symbol appears in the 'Expression' box.

8. Leaving the 'sgtbl_EmployeeCumulative' selected, choose the variable for 
'AVCAmountTD', and click 'Add' (or double click on the variable to select it).

9. You have now completed the expression, and can click 'OK'.

The 'Object Properties' window reappears, displaying the expression you have just built.
           

Use the other tabs to set the properties for this expression.

10. Once you are happy with the expression, click 'OK'.

The expression is added to the report. You can now add a title and total if you require.
           

Clear This button clears the 'Expression' area, so you can start to 
create your expression again.
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Further examples of simple expressions
          

Once you have created an expression such as the 'Tot EE Pens Cont' used in an earlier 
example, you can use that expression as you would a standard variable and include it within 
new expressions.

For example, you may now want the Employee Pension Contributions report to also calculate 
the total of Employee's and Employer's contributions.

Sage 50 To divide the prior year value by 12 then multiply by 6, select from 
the 'Variables' list and use the operand buttons to enter the 
following:

('SALES_LEDGER'.'PRIOR_YEAR'/12)*6

Or, to add the invoices for months 1 and 2 then subtract the total 
of the credits for months 1 and 2, enter the following:

('SALES_LEDGER'.'INVOICE_MTH1'+'SALES_
LEDGER'.'INVOICE_MTH2') - 
('SALES_LEDGER'.'CREDIT_MTH1'+'SALES_
LEDGER'.'CREDIT_MTH2')

Sage Payroll To find out the total of Employee and Employer NIC contributions 
for each employee to date, enter:

'sgtb_EmployeeCumulative'.'EmployerNICTD' + 
'sgtb_EmployeeCumulative'.'EmployeeNICTD'

Sage Job Costing To show the budget value for a job divided by 12, use:

'tblJobCost'.'BudgetValue'/12

Or, to calculate the difference between the original budget value 
and revised budget value for a job, use:

'blJobCost'.'BudgetValue' - 'tblJobCost'.'RevisedBudgetValue'
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Using the 'Expression Builder' as before, you can now choose 'Tot EE Pens Cont' from the 
variable list, and add it to the 'PensEmployerTD' variable.

You can then follow the steps to create your expression as previously detailed, amending the 
object properties if you require, and adding a title and total.
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Sections

When you create a report, the Report Designer automatically divides it into sections.
           

A simple report consists of the following sections:

Page Header

Details

Page Footer.

If you add a group to your report, for example to list all items which have the same account 
reference together, this changes the sections on your report to:

Page Header

Account_Ref Header

Details

Account_Ref Footer

Page Footer.

If you add another group to the report using the same variable, the section names are appended 
with a 2 as follows:

Page Header

Account_Ref header

Account_Ref header 2

Details

Account_Ref footer

Account_Ref footer  2

Page Footer.

This numbering system continues with consecutive numbers for every additional group section 
name. If you delete a group, the sections will re-number accordingly.

Note: To view further details about the section, from the 'Object' toolbar select the 'Tooltips' 
button. Move the cursor over the section name and additional information is displayed about 
the section.
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Use the 'Sections' option from the 'Format' menu to change the properties of each section. You 
can set:

The height of each section

Whether to print the section

Whether to print the section if a particular condition (filter) is true or false. For example, you 
could print the section only if the sales account reference is between C001 to C999, or not 
between C001 to C999

Whether to show this section on the report layout

Whether to insert a page break after this section

Whether to suppress the page header on the first page

Whether you want to remove a section from the report.

To set section properties

1. From the 'Format' menu, choose 'Sections'.

The 'Sections' window appears.

2. Select the section you want to amend and then click 'Modify'.

The 'Section Options' window appears.
           

In the boxes provided, enter the following details:
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3. To save your section details, click 'OK'.

Height Enter the height of the section. Use the up and down arrows 
to make fine adjustments if necessary.

Note: When you add an object to a section, the Report 
Designer automatically changes the height of the section for 
you.

Tip: You can also alter the height of a section. Position the 
mouse over the lower line of the section you want to change, 
press and hold down the mouse button, and drag the section 
line to the new position you require. Release the mouse button, 
and the new section height is set.

Print From the drop-down list, select either to 'Always print the 
section', never print the section, only print the section 'if filter 
true', or only print the section 'if filter false'.

If you make a selection which is dependent on a filter, click the 
'Filter' tab to set up the filter you require. For more information 
about how to set up your filter, see the Adding Filters section 
earlier in this chapter.

Visible on design 
window

Select this check box if you want to show this section on the 
report layout.

Clear the check box to remove the section.

Page break Select this check box to insert a page break after this section.

Align to top of page 
(page header sections 
only)

Select this check box if you want to align the section to the 
top of the report page

Align to bottom of page 
(page footer sections 
only)

Select this check box if you want to align the section to the 
bottom of the report page.

Appear on first page 
only (page header 
sections only)

Select this check box if you only want to show the information 
from the page header section on the first page of your report.

Appear on last page 
only (page footer 
sections only)

Select this check box if you only want to show the information 
from the page footer section on the last page of your report.
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4. To return to the Report Designer, click 'Close'.

To disable a section

1. From the 'Format' menu, choose 'Sections'.

The 'Sections' window appears.

2. Select the section you want to disable and click 'Modify'.

The 'Section Options' window appears.

3. Clear the 'Visible on design window' check box.

4. From the 'Print' drop-down list, select the 'Never'

5. Click 'OK'.

6. To return to the Report Designer, click 'Close'.

The section is now omitted from your report.

Adding Extra Page Sections

If you want to show only certain information on the first and last pages of your reports, such as 
the date range you are running your report for, the transaction number range, or the page count, 
you can add extra page sections to your reports.

To add extra page sections

1. From the 'Format' menu, choose 'Sections'.

The 'Sections' window appears.

2. Click 'Add Section'.

A new page header and page footer section is added to your list of existing sections.

3. Select the newly created page header section and click 'Modify'.

The 'Section Options' window appears.

4. In the boxes provided, enter the details as described in step 3 of the To set section 
properties procedure, earlier in this chapter.

5. To save your section details, click 'OK'.

6. To return to the Report Designer, click 'Close'.
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Chapter 6

Creating Example Reports
In this chapter:
Remember.... ...................................140

Creating a Report Using the Report 
Wizard .............................................141

Creating a Report Which Groups Each 
Customer's Transactions Using the 
Report Wizard..................................164

Using Expressions to Calculate the 
Available Credit for Each Customer's 
Account...........................................169

Using Filters to Show Only Those 
Customers Who Have Exceeded Their 
Credit Limit ......................................172

Using Criteria to Select Which 
Customers Appear on Your Report ..174

Removing the Details Section from Your 
Report to Produce a Summary ........176
Work through the example reports in this 
chapter to familiarise yourself with the 
Report Designer's features.

This chapter includes examples showing 
how to use the Report Wizard to create 
reports in Sage 200, Sage 50, Sage 
Instant Accounts Plus, Sage Payroll/
Payroll Professional and Sage Job 
Costing.

While the examples in the chapter relate 
specifically to one Sage product, the 
processes described can also be applied 
to create reports in the Report Designer in 
any Sage product.



Remember....

....you can use the following shortcut keys:
          

CTRL+A Selects all the objects (variables, text and graphics) on the report. If 
required, you can then move all these selected objects together.

CTRL+B Changes the text in the selected objects to bold.

CTRL+C Copies the selected objects to the Report Designer's clipboard. 
You can then paste these objects into any report.

CTRL+I Changes the text in the selected objects to italics.

CTRL+N Starts the Report Wizard. This lets you create a new report.

CTRL+O Opens an existing report.

CTRL+P Prints your report.

CTRL+S Saves any changes you have made to the current report.

CTRL+U Underlines the text in the selected object.

CTRL+V Pastes whatever is held in the Report Designer's clipboard into the 
current report.

CTRL+X Removes the selected objects from the report layout and stores 
them in the Report Designer's clipboard. You can then paste these 
objects into any report.

CTRL+Z Cancels the previous action. This lets you undo mistakes.



 Creating Example Reports
Creating a Report Using the Report Wizard

This section contains examples of reports created using the Report Wizard for Sage 200, Sage 
50, Sage Instant Accounts Plus, Sage Payroll and Sage Job Costing.

Creating a Supplier Balances Report (Sage 200)

This example creates a Supplier Balances Report using the Report Wizard. The report contains 
each supplier's account reference, company name and account balance. The accounts are 
then sorted to show the supplier with the highest balance first on the report. Such a report 
would allow you to see the accounts where you should contact your supplier or pay some 
invoices.

The steps in this procedure show how to move and edit the details displayed in the previous 
example report. While the report is a Sage 200 report, the process here applies to the Report 
Designer in all Sage products (except the Sage Forecasting suite).

To use the Report Wizard to create your Supplier Balance report

1. From the Sage 200 main toolbar, click 'Report Designer'.

2. Select the 'Financials Reports' option.

The Report Designer Browser appears.

3. From the Report Designer Browser's main toolbar, click 'File' and then 'New'.

The Report Designer's Sage Report Wizard appears displaying the Introduction page.

4. Click 'Next'.

The 'Document Type' page appears. This displays all of the basic report types for the 
Financials modules in Sage 200.
 141



Sage Report Designer User’s Guide

1

           

For this example, you need a report that accesses the tables for the supplier accounts.

5. From the 'Report' tab, select the 'Purchase Ledger Report'. In the 'Enter a document 
description box', type Supplier Account Balances Report.

6. Click 'Next'.

The 'Variables' page appears. This lists all information associated with the selected report. 
In this case, the 'Variables' page shows all information relating to the supplier records on 
your Sage 200 system.
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7. From the 'Table' drop-down list, select the 'PLSupplierAccount' table.

The 'Variables in the Table' list changes to show all the variables available in the selected 
table.

8. From the 'Variables in the Table' list, select the 'SupplierAccountNumber' variable and 
click 'Add'. This copies the variable to the 'Variables on the Report' list.

Copy the 'SupplierAccountName', 'CreditLimit' and 'AccountBalance' variables in the 
same way so that they are displayed as they are in the figure above.

9. Click 'Next' to move to the next page in the Wizard.

The 'Variable Sizes' page appears.

You can use this page to set the number of characters you want the variable to generate, 
and the width of the variables on your report. At this point you can choose 'Preview' to see 
how the report looks. You can see if the field lengths are the right size; if they are too small 
the text or numbers in the report will not be fully displayed. However, you can change these 
field lengths manually once you have finished entering information into the Sage Report 
Wizard. We will do this later in the example.

10. Click 'Next'.

The 'Groups' page appears. You can use this page to group information on your report. 
We do not need to group any variables for this report.

11. Click 'Next'.

The 'Sorts' page appears. From here you can specify whether the variables should be 
sorted in ascending or descending order.

The 'Variables' 
list displays the 
variables 
available for the 
table you have 
selected.

As you select 
variables from 
the Purchase 
Ledger list they 
appear here.
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12. Add the variable 'AccountBalance', so that it appears in the 'Variables to Sort By' list.

13. Click on the 'Asc' button, and select 'Descending Order' from the pop-up menu.

The button changes to 'Dsc'. The details on the report will be sorted in descending 
account balance.

14. Click 'Next'.

The 'Totals' page appears. This is where you can specify if you want a monetary value to 
be totalled on the report. Any numeric variables are listed in the 'Variables to Total' by 
default.

15. Click 'Next'.

The 'Criteria' window allows you to restrict the data that appears on your report. In Report 
Designer you are often prompted to enter date and record criteria before you run a report. 
This page of the Wizard allows you to set up these criteria for your new report.

By default the status of each criteria is set to 'Disabled'. Set the criteria option to 'Enabled' 
if you want to be prompted to enter a criteria variable every time you run the report. This 
example is using the demonstration data supplied with Sage 200 which is relatively small 
in size, but if you had a large amount of data, you may want to set some criteria to allow 
you to filter your information by date, transaction number or by supplier.

16. Click 'Next'.

The 'Print Options' page is displayed. This allows you to set up the default print settings 
for this new report. From here you can specify paper size, orientation and the paper tray 
that should be used by your printer.

Note: You should specify the paper size that is placed in your printer so that it is the same 
that is specified in the 'Paper size' drop-down list.

17. Click 'Preview' to view how the report looks with your data. You can see if you need to go 
back some steps to edit what you have entered. Click 'Close' to go back to the Sage 
Report Wizard. Alternatively, you can click 'Finish' to close the Sage Report Wizard and 
work on the design of the finished report.

In this example, it is easier to edit the report manually.

The 'Design' tab of the report looks like this:
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Clicking on the 'Preview' tab shows how the report would look when it is printed:
           

In this example, you can see that the 'Credit Limit' column is on the far right of the page. 
The report would look better if the 'Account Balance' and 'Credit Limit' columns were 
swapped around. The next procedure will show how you can manually change the look of 
the report.
 145



Sage Report Designer User’s Guide

1

To edit the report manually
The steps in this procedure show how to move and edit the details displayed in the previous 
example report. While the report is a Sage 200 report, the process here applies to all Sage 
products that use the Sage Report Designer.

1. With the report open, select the 'Design' tab.

2. Select the 'CreditLimit' field and swap its position with the 'AccountBalance' field in the 
'SupplierAccountNumber' header section.

This swaps the values displayed on the report so that the credit limit is listed alongside the 
account name. The account balance will now be displayed on the right side of the report.

3. Do the same with the 'CreditLimit' field and 'AccountBalance' fields in the Report Header 
2 section.

This swaps the column headings so that they are above the correct values in the report.

At the moment, the 'AccountBalance' and 'CreditLimit' fields are in the incorrect place on 
the 'Page Footer' area of the report. You do not need a total for the 'CreditLimit' field as a 
credit limit only applies to the individual supplier account, so this can be removed from the 
report.

4. Arrange the 'Page Footer' area of the report so it looks like this:
           

The report will look similar to this when you select the 'Preview' tab:
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The report is almost complete, however the titles of are still based on the variable names 
from the selected tables. These should be edited so they are more meaningful.

5. Select the 'Design' tab. We will now replace the default variable names with some text 
boxes.

6. Delete the first variable name in the 'Report Header 2', 'Supplieraccountnumber' by 
clicking on the right-hand mouse button and selecting 'Clear'. Alternatively, select the 
report variable and then press the DELETE key on your keyboard.

7. Select the 'Text' icon (the T picture) from the toolbar.

The mouse pointer changes to a cross-hair.

8. Click on the area where you want to put the text.

A text box will appear on the report.

9. Enter the text in the text that you want to display in the report, in this case 'Account 
Number'.

If necessary you can change the font size and colour of the text. To do this, click on the 
title, select 'Edit' and then 'Properties'.

10. Continue to do this for the rest of the variable titles.

Remember to check how the report looks, by clicking on the 'Preview' tab. Once you have 
renamed all of the variables, you can make further adjustments to the layout of your report. 
For example, this shows what the report could look like:
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Creating a Customer Balances Report (Sage 50 and Instant Accounts 
Plus)

This example creates a Customer Balances Report using the Report Wizard. The report 
contains each customer's account reference, company name, credit limit and account balance. 
The accounts are sorted to show the customer with the lowest balance first on the report.

To use the Report Wizard to create your Customer Balance report

1. From the Sage 50 or Sage Instant Accounts Plus main toolbar, click 'Reports'.

The Report Designer Browser appears.

2. From the Report Designer Browser's main toolbar, click 'New'.

The Report Wizard appears displaying the Introduction page.

3. Click 'Next'.

The 'Document Type' page appears.
           

4. From the 'Report' tab, select the 'Customer' option. In the 'Enter a document description' 
box, type 'Customer Balances' and then click 'Next'.

The Report Variables page appears.
48



 Creating Example Reports
           

5. From the 'Table' drop-down list, select the 'SALES_LEDGER' table.

The 'Variables' list changes to show all the variables available in the 'SALES_LEDGER' 
table.

6. From the 'Variable' list select the 'ACCOUNT_REF' variable and click 'Add>'. This copies 
the 'ACCOUNT_REF' variable to the 'Report Variables' list.

Copy the 'NAME' and 'BALANCE' variables in the same way.

7. Click 'Next'.

The 'Variable Sizes' page appears.

You can use this page to set the number of characters you want the variable to generate, 
and the width of the variables on your report. However, we are not changing the variable 
characters or width on this report, so do not need to do anything on this page.

8. Click 'Next'.

The 'Groups' page appears.

You can use this page to group information on your report. However, we are not adding 
groups to this report, so do not need to do anything on this page.

9. Click 'Next'.

The 'Sorts' page appears.

The 'Variables' list 
displays the 
variables available 
for the table you 
have selected.

As you select 
variables from the 
Sales Ledger list 
they appear here.
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10. Select the 'SALES_LEDGER.BALANCE' variable then click 'Add >'.

The 'SALES_LEDGER.BALANCE' variable appears in the 'Sort Variables' list.

Note: To see a preview of the report you can click the 'Preview' button at any time.

11. Click 'Finish'.

The 'Report Designer' window appears, showing your report layout. Your report layout 
should look like the following.

           

Note: The report is automatically set so that the customer with the lowest balance is 
displayed first.

You are now ready to save and print your report.

To save and print your Customer Balances report

1. From the 'File' menu, choose 'Save As'.

The 'File Save As' window appears.

2. From the 'Save in' drop-down list, select the folder where you want to store the report.
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Tip: If you save this report into your 
C:\Program Files\Accounts\Reports\Customer directory, it appears in your Customer 
Reports window in Sage 50 or Instant Accounts Plus.

3. In the 'Filename' box, enter 'Custbal' as the name for the report.

4. Click 'OK'.

Your report is now saved.

5. To print your report, from the Status bar click the 'Preview' tab. Then, from the main 
toolbar, click the 'Print' option.

The 'Print' window appears.

6. Click 'OK'.

Your printed report should look similar to the following.
           

Congratulations, you have now printed your Customer Balances report!

You could now try to create this report manually. For further information, see the Creating 
a Report Manually section, later in this chapter.

Creating an Employee Details Report (Sage Payroll/Payroll 
Professional)

This example creates an employee report which shows the name, address and National 
Insurance number for all your employees. This report is useful if the Contributions Agency 
requests this information. The employees are sorted to show the Surnames in alphabetical 
order.
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To use the Report Wizard to create your Employee Details report

1. From the Sage Payroll/Payroll Professional main toolbar, click 'Reports'.

The 'Reports' window appears.

2. From the Reports toolbar, click 'New'.

The Report Wizard appears displaying the Introduction page.

3. Click 'Next'.

The 'Document Type' page appears.
           

4. From the 'Report' tab, select the 'Employee' option. In the 'Enter a document description' 
box, type 'Employee Details Report' as the description for your report, then click 'Next'.

The 'Report Variables' page appears.
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5. From the 'Table' drop-down list, select the 'sgtbl_EmployeePersonal' table.

The 'Variables' list changes to show all the variables available in the 
'sgtbl_EmployeePersonal' table.

6. From the 'Variables' list, select the 'Surname' variable then click 'Add>'. This copies the 
'Surname' variable to the 'Report Variables' list.

Copy the 'Forename', 'Address1', 'Address2', 'Address3', 'Address4', 'Address5', 
'Postcode' and 'NI Number' variables in the same way.

If you make a mistake, simply select the incorrect variable from the 'Report Variables' list 
and click '< Remove'. The selected variable is removed from the 'Report Variables' list.

7. Click 'Next'.

The 'Variable Sizes' page appears.

You can use this page to set the number of characters you want the variable to generate, 
and the width of the variables on your report. However, we are not changing the variable 
characters or width on this report, so you do not need to do anything on this page.

8. Click 'Next'.

The 'Groups' page appears.

You can use this page to group information on your report. However, we are not adding 
groups to this report, so you do not need to do anything on this page.

9. Click 'Next'.

The 'Sorts page' appears.
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10. Select the 'sgtbl_EmployeePersonal.Surname' variable and click 'Add >'.

The 'Surname' variable appears in the 'Sort Variables' list.

Note: To see a preview of the report you can click the 'Preview' button at any time.

11. Click 'Finish'.

The Report Designer window appears, showing your report layout.

Your report layout should look like this:
           

You are now ready to arrange your variables.

To arrange your variables
The Report Wizard places all text headings and variables on the report layout from right to left, 
in the order you selected them using the Report Wizard. Therefore, all you need to do is arrange 
these so they are in the correct places, using the drag and drop method, and remove those 
headings that you do not need.
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1. Delete the following text headers which you do not require, from the 'Page Header' 
section: 'Address2', 'Address3', 'Address4', 'Address5' and 'Postcode'.

To delete a text header, select the text header and press the 'DELETE' key. The text 
header is deleted.

2. You now need to re-arrange your text headers and variables.

To move a variable, click the variable and while holding down the mouse button, drag the 
variable to the required position then release the mouse button. Alternatively, select the 
variable and use the arrow keys to position the variable.

3. Once you have re-arranged your text and variables you need to adjust the height of the 
section. To do this click the lower line of the section you require. Hold the mouse button 
down and drag the section line to the position you require and then release the mouse 
button.

When you have finished this section your report layout should look like this:
           

You can preview how the report will print by clicking the 'Preview' tab at any time.

You are now ready to save and print your new Employee Details Report.

To save and print your Employee Details report

1. From the 'File' menu, choose 'Save As'.

The 'File Save As' window appears.

2. From the 'Save in' drop-down list, select the folder where you want to store the report.

Tip: If you save this report into your C:\Program Files\Sage Payroll\Reports\Employee 
folder, it will appear in the 'Employee Reports' folder in the 'Reports' window.

3. In the 'Filename' box enter a name for the report.

4. Click 'OK'.

Your report is now saved.

5. To print your report, from the Status bar click the 'Preview' tab. Then from the main 
toolbar, click 'Print'.

The 'Print window' appears.
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6. To print your report, click 'OK'.

Your printed report should look similar to the report shown below:
           

You have now printed your Employee Details report.

Creating a Job Details Report (Sage Job Costing)

This example creates a Job Details Report using the Report Wizard. The report contains the job 
number, title and value. The jobs are sorted to show the job with the lowest quoted price first 
on the report.

To use the Report Wizard to create your Job Details report

1. From the Sage Job Costing main toolbar, click 'Reports'.

The Reports window appears.

2. From the 'Reports' toolbar, click 'New'.

The Report Wizard appears displaying the 'Introduction' page.

3. Click 'Next'.

The 'Document Type' page appears.
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4. From the 'Report' tab, use the scroll bar to view the options at the bottom of the tab and 
select the 'Job Analysis' option. In the 'Enter a document description' box, type 'Job 
Details Report' as the description for your report, then click 'Next'.

The 'Report Variables' page appears.
           

5. From the 'Table' drop-down list, select the 'tblJob' table.

The 'Variables' list changes to show all the variables available in the 'tblJob' table.

6. From the 'Variables' list, select the 'JobNo' variable then click 'Add >'. This copies the 
'JobNo' variable to the 'Report Variables' list.
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Copy the 'Title' and 'Value' variables in the same way.

If you make a mistake, simply select the incorrect variable from the 'Report Variables' list 
and click '< Remove'. The selected variable is removed from the 'Report Variables' list.

7. Click 'Next'.

The 'Variable Sizes' page appears.

You can use this page to set the number of characters you want the variable to generate, 
and the width of the variables on your report. However, we are not changing the variable 
characters or width on this report, so you do not need to do anything on this page.

8. Click 'Next'.

The 'Groups' page appears.

You can use this page to group information on your report. However, we are not adding 
groups to this report, so you do not need to do anything on this page.

9. Click 'Next'.

The 'Sorts' page appears.
           

10. Select the 'tblJob.Value' variable then click 'Add >'.

The 'tblJob.Value' variable appears in the 'Sort Variables' list.

Note: To see a preview of the report you can click the 'Preview' button at any time.

11. Click 'Finish'.

The Report Designer window appears, showing your report layout. Your report layout 
should look like the following:
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You are now ready to save and print your Job Details report.

To save and print your Job Details report

1. From the 'File' menu, select the 'Save As' option.

The 'Save As' window appears.

2. From the 'Save in' drop-down list, select the folder where you want to store the report.

Tip: If you have a single user version of Sage Job Costing and save this report into your 
C:\Program Files\Sage Job Costing\Reports\Job Analysis folder, it appears in your Job 
Analysis folder in the Sage Job Costing Reports window.

3. In the 'Filename' box enter a name for the report.

4. Click 'OK'.

Your report is now saved.

5. To print your report, from the Status bar click the 'Preview' tab. Then from the main 
toolbar, click 'Print'.

The 'Print' window appears.

6. To print your report, click 'OK'.

Your printed report should look similar to the report shown below:
           

Congratulations, you have now printed your Job Details report.
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Creating a Report Manually

This section contains an example of how to create a report manually. The example creates a 
blank Customer Balances Report using the Report Wizard, and explains how to finish creating 
the report manually. The report contains each customer's account reference, company name 
and account balance. The accounts are sorted to show the customer with the lowest balance 
first on the report.

Creating this report consists of the following procedures:

Using the Report Wizard to create a blank report, with the title of 'Customer Balance'.

Inserting the variables for your report (customer account reference, company name and 
balance).

Inserting headings for your columns ('Account Reference', 'Company Name' and 
'Balance').

Adding a sort so the lowest customer balance appears first on the report.

To create your blank Customer Balance report

1. From the Sage 50 main toolbar, click 'Reports'.

The Report Designer Browser appears.

2. From the Report Designer Browser's main toolbar, click 'New'.

The Report Wizard appears displaying the 'Introduction' page.

3. Click 'Next'.

The 'Document Type' page appears.

4. From the 'Report' tab, select the 'Customer' option. In the 'Enter a document description' 
box, type 'Customer Balance' as the description for your report.

5. Click 'Finish'.

The Report Designer window appears showing your blank Customer Balance report. Your 
blank report should look like the following:

           

You are now ready to add the variables to your report.
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To add the variables to your Customer Balance report

1. From the Object toolbar, click the 'Variables' option.

2. From the 'Table' drop-down list on the 'Object' toolbar, select the 'SALES_LEDGER' table.

The 'Variable' drop-down list shows the variables for the 'SALES_LEDGER' table.

3. From the 'Variable' drop-down list, select the 'ACCOUNT_REF' variable, then click in the 
'Details' area of the report at the position you want it to appear.

Repeat this to add the 'NAME' and 'BALANCE' variables.

Note: If a variable does not appear exactly where you want it on your report, then click the 
variable with your mouse and use the arrow keys to move the variable to the new position. 
You may want to reduce the width of the 'NAME' variable so that the company name and 
balance information is closer together on the report.

The report layout should now look like the following:
           

Now you have inserted your variables you are ready to add the text for your column 
headings.

To add column headings

1. From the 'Object' toolbar, click the 'Text' option.

The cursor changes to a cross shape.

2. Click the report layout at the position where you want to insert the text for your column 
heading 'Account Reference'.

Type the words 'Account Ref’ and the text you enter appears surrounded by a box.

Repeat this step to insert your column heading for the 'Name' and 'Balance' columns.

Note: If a column heading does not appear exactly where you want it on your report, then 
click on the column heading with your mouse and use the arrow keys to move it to the new 
position.

3. To change the headings to bold, double-click on the column heading.

The 'Object Properties' window appears.

4. Click the 'Font' tab, and select 'Bold' from the 'Font style' list.

5. To save the font setting, click 'OK'.
 161



Sage Report Designer User’s Guide

1

Repeat the above steps for all of your column headings.

The report layout should now look like the following:
           

Now that you have added your column headings you are ready to add a sort to show the 
customer with the lowest balance first on your report.

To add a sort to your Customer Balance report

1. From the 'Format' menu, choose 'Sorts'.

The 'Sorts' window appears.

2. Click 'Add'.

The 'Add Sort' window appears.

3. From the 'Report Variables' list, select the 'SALES_LEDGER.BALANCE' variable. Then 
select the 'Ascending' option button, so the customer with the lowest balance appears first 
on your report.

4. To save your sort, click 'OK'.

5. To return to the Report Designer window, click 'Close'.

You have finished creating your report. You should now save and print the report as 
required.

The printed report should look similar to the following:
62



 Creating Example Reports
           

Now you have used the Report Wizard to create a report, and also created a report 
manually, why not try creating the other example reports in this chapter.
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Creating a Report Which Groups Each
Customer's Transactions Using the Report
Wizard

This example creates a 'Customer Balance with History' report using the Report Wizard. The 
report shows the transactions which make up the balance for each customer account. All the 
items for one sales account reference are shown together by using the 'Group' option.

The report contains each customer's account reference, company name and account balance, 
as well as the following columns: transaction number, type, date, details, net amount, tax 
amount and gross amount per customer.

In this example, you will be:

Using the Report Wizard to create your Customer Balance with History report, with the 
variables which will appear in the main body of your report, each with its own column 
heading.

Adding a group to the report so that the variables are grouped by account reference and 
adding a total per customer.

Arranging the text and variable objects on your report.

Changing the style of the total variables on your report to over and underlined.

To use the Report Wizard to create your Customer Balance with History 
report

1. From the Sage 50 main toolbar, click 'Reports'.

The Report Designer Browser appears.

2. From the Report Designer Browsers main toolbar, click 'New'.

The 'Report Wizard' appears displaying the 'Introduction' page.

3. Click 'Next'.

The 'Document Type' page appears.

4. From the 'Report' tab, select the 'Customer' option. In the 'Enter a document description' 
box, type Customer Balance with History, as the description for your report.

5. Click 'Next'.

The 'Report Variables' page appears.

6. From the 'Table' drop-down list, select the 'SALES_LEDGER' table.

The 'Variables' list changes to show all the variables available in the 'SALES_LEDGER' 
table.
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7. From the 'Variables' list, select the 'ACCOUNT_REF' variable then click 'Add >'. 
The 'ACCOUNT_REF' variable is copied into the 'Report Variables' list.

Copy the 'NAME' and 'BALANCE' variables in the same way.

8. From the 'Table' drop-down lists, select the 'AUDIT_HEADER' table.

The variables in the 'Variables' list change to show those that are applicable for the 
'AUDIT_HEADER' table.

Copy the following variables to the 'Report Variables' list:

'TRAN_NUMBER', 'TYPE', 'DATE', 'DETAILS', 'NET_AMOUNT', 'TAX_AMOUNT' and 
'GROSS_AMOUNT'.

9. Click 'Next'.

The 'Variable Sizes' page appears.

You can use this page to set the number of characters you want the variable to generate, 
and the width of the variables on your report. However, we are not changing the variable 
characters or width on this report, so you do not need to do anything on this page.

10. Click 'Next'.

The 'Groups' page appears.
           

11. Select 'SALES_LEDGER.ACCOUNT_REF' from the 'Report Variables' list, then click 
'Add'.

The 'SALES_LEDGER.ACCOUNT_REF' variable is copied into the 'Group Variables' list.

12. Click 'Next'.
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The 'Sorts' page appears. Because you set up the 'ACCOUNT_REF' variable as a group, 
a sort is automatically added to the 'ACCOUNT_REF' variable for you. Therefore you do 
not need to do anything on this page.

13. Click 'Finish'.

The Report Designer window appears, showing your report layout.

The report layout should look like the following:
           

You are now ready to arrange the text and variable objects on your report.

To arrange the text and variable objects on your Customer Balance with 
History report

1. Delete the 'BALANCE' variables in the 'ACCOUNT_REF Footer' and 'Page Footer' section 
of the report, by clicking on the variable and pressing the DELETE key.

2. Decrease the width of the 'NAME' and 'DETAILS' variables to about half their original size.

3. Select the 'ACCOUNT_REF' variable.

The cursor changes to a cross shape.

4. Using the arrow keys or the mouse, move the variable to the new position on your report.

Then, repeat steps 1 and 2 again to move the following variables:

'NAME', 'BALANCE', 'TRAN_NUMBER', 'TYPE', 'DATE', 'DETAILS', 'NET_AMOUNT', 
'TAX_AMOUNT' and 'GROSS_AMOUNT'. Then, move the column headings for these 
variables.

The report layout should now look as follows:
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Now you have arranged the text headings and the variables on your report you are ready 
to change the style of your total variables to over and underlined.

To change the style of your total variables to over and underlined

1. Select the 'NET_AMOUNT' variable from the 'ACCOUNT_REF' Footer section of your 
report.

The cursor changes to a cross shape.

2. From the 'Style' drop-down list, select the style 'Sub Total'.

The 'NET_AMOUNT' variable on your report changes to over and underlined.

3. Repeat steps 1 and 2 for the following variables appearing in the 'ACCOUNT_REF' Footer 
of your report:

'TAX_AMOUNT' and 'GROSS_AMOUNT'.

4. Repeat steps 1 and 2 for the following variables appearing in the Page Footer area of your 
report:

'NET_AMOUNT', 'TAX_AMOUNT' and 'GROSS_AMOUNT'.

You have changed the styles of the total variables appearing on your report. You can now 
save and print the report as required.

The report should look similar to the following:
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Congratulations, you have now created your Customer Balance with History report!
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Using Expressions to Calculate the Available Credit for Each 
Customer's Account

Using the report you created in the Creating a Report Which Groups Each Customer's 
Transactions Using the Report Wizard section on page 164, add an expression (calculation) to 
show the available credit on each of your customers accounts. For further information about 
expressions see the section Creating Expressions in the chapter Advanced Features of the 
Report Designer.

Adding an expression to your Customer Balance with History report consists of the following 
procedures:

Using the Customer Balance with History report created in the Creating a Report Which 
Groups Each Customer's Transactions Using The Report Wizard section, and adding an 
expression (calculation) to show the available credit on the customer's account.

Inserting a heading for the expression column.

To add an expression to your Customer Balance with History report

1. From the 'Object' toolbar, click the 'Expression' option.

The cursor changes to a cross shape.

2. Click on the report at the point you want to insert the expression (at the right hand side of 
the 'ACCOUNT_REF' Header section).

The expression object appears on your report surrounded by a box.

3. Double-click the expression object.

The 'Object Properties' window appears.

4. In the 'Name' box, type 'Over-Credit?'

5. Click 'Build'.

The 'Expression Builder' window appears.
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6. From the 'SALES_LEDGER' table, select the 'BALANCE' variable and then click 'Add'.

The 'BALANCE' variable is copied into the 'Expression' box.

7. Select the '-' (minus) button under the 'Expression' box.

A minus sign appears after the 'SALES_LEDGER.BALANCE' variable.

8. Now, select the 'CREDIT LIMIT' variable from the 'SALES_LEDGER' table and click 'Add'.

The 'CREDIT LIMIT' variable is copied into the 'Expression' window.

9. To save the expression, click 'OK'.

The 'Object Properties' window is displayed.

10. To return to the Report Designer window, click 'OK'.

The Report Designer window appears, showing your report layout with the expression you 
have just added.

You are now ready to add the text for the column heading of the expression.

To add a column heading

1. From the Object Toolbar, select the Text option (a T, second from the left).

The cursor changes to a cross shape.

2. Click on the report layout at the position where you want to insert the text for the column 
heading of the expression and start typing, for example, at the right hand side of the 
'ACCOUNT_REF' Header section.

Type the words 'Over Credit?' and the text you enter appears surrounded by a box.
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Your report layout should look like the following:
           

Note: If a column heading does not appear exactly where you want it on your report, then 
click the column heading with your mouse and use the arrow keys to move it to the new 
position.

3. Select the column heading 'Over Credit?'.

The cursor changes to a cross shape.

4. From 'Style' drop-down list, select the style 'Heading'.

The 'Over Credit?' column heading on your report changes to bold and is underlined.

You should now save and print your report.

The report should look similar to the following:
           

Using this report as a basis, follow the next example to set up a filter so that only those 
customers who have exceeded their credit limit are included on the report.
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Using Filters to Show Only Those Customers Who Have 
Exceeded Their Credit Limit

This example uses the Customer Balance with History report previously created in the Using 
Expressions to Calculate the Available Credit for Each Customer's Account section on page 
169 and sets up a filter on the report. The filter is set up on the expression (calculation) 
Sales_Ledger.Balance - Sales_Ledger.Credit Limit so that only those customers who have 
exceeded their credit limit are included. The title of the report is also changed to reflect the new 
information printed on the report.

For further information about filters see the section Adding Filters in the chapter Advanced 
Features of the Report Designer. Inserting a filter on to your Customer Balance with History 
report consists of the following procedure:

Using the Customer Balance with History report created in the Using Expressions to 
Calculate the Available Credit for Each Customer's Account section on page 169, and 
setting up a filter, using the Filter option.

To set up a filter on the expression you previously created on your Customer 
Balance with History report

1. From the 'Format' menu, choose 'Filter'.

The 'Filter' window appears.

2. Click 'Build'.

The 'Filter Builder' window appears.
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3. From the 'Report' table, select the expression variable 'Over Credit?' and then click 'Add'.

The 'Over Credit?' variable appears in the 'Filter' window.

4. Click '>' (greater than).

The '>' sign appears and the cursor is positioned at the end of the text in the Filter window.

5. Type 0 (zero) in the Filter window and then click 'OK'.

The Filter window reappears.

6. To return to the Report Designer window, click 'OK'.

You have now created a Customer report showing only those customers who have 
exceeded their credit limit.

You should save this report as the Customer History Over Credit Limit Report.

Using this report, follow the next example to set up criteria so that each time you run the 
report a 'Criteria' window appears asking you to enter the Customer Account range you 
want to run the report for.
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Using Criteria to Select Which Customers Appear on Your 
Report

Using the report you created in the section, Using Filters To Show Only Those Customers Who 
Have Exceeded Their Credit Limit, set up criteria so you can run your report for a specific range 
of customers. For further information, see the Setting Criteria section in the Advanced Features 
of the Report Designer chapter.

Adding Criteria to your Customer Histories Over Credit Limit report consists of the following 
procedure:

Using the Customer Histories Over Credit Limit report created in the section Using Filters 
to Show Only Those Customers Who Have Exceeded Their Credit Limit and adding 
criteria, using the Criteria option, so you can select which customer accounts are shown 
on your report.

To add criteria to your Customer Histories Over Credit Limit report

1. From the 'Format' menu, select the 'Criteria' option.

The 'Criteria' window appears.
           

2. Click the cursor on the 'Status' box of the 'Customer Ref' variable and select the 'Enabled' 
option from the drop-down list.

3. To save your criteria, click 'OK'.

4. To return to the 'Report Designer' window, click 'OK'.

You have added the criteria to your report.
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You should now save and print the report. You have now created a customer report 
showing customers who have exceeded their credit limit, within a specified range.

Using this report, follow the next example to remove the 'Details' section from your 
Customer Histories Over Credit Limit report so that when you run the report, the 
information is summarised.
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Removing the Details Section from Your Report to Produce 
a Summary

Using the report you created in the Using Criteria To Select Which Customers Appear On Your 
Report section, remove the Details section to produce a summarised report showing only the 
balances of those customers who have exceeded their credit limit.

The title of the report is also changed to reflect the new information printed on the report. For 
further information, see the Sorting Report Information section in the Advanced Features of the 
Report Designer chapter.

Removing a section on your Customer Histories Over Credit Limit report consists of the 
following procedures:

Using the Customer Histories Over Credit Limit report created in the Using Criteria to 
Select Which Customers Appear on Your Report section, and removing the Details section 
of the report, using the Sections option, to produce a summarised report

Removing the text column headings no longer required on your report

Re-arranging the text and variable objects on your report.

To remove the Details section on your Customer Histories Over Credit Limit 
report

1. From the 'Format' menu, choose 'Sections'.

The 'Sections' window appears.
           

2. Select the 'Details' section and click 'Modify'.

The 'Section Options' window appears.
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3. From the 'Print' drop-down list, select the 'Never' option, to stop the Details section 
printing on your report.

4. Clear the 'Visible on designer window' check box to remove the Details section from your 
report layout.

5. To save your settings, click 'OK'.

The 'Sections' window is displayed again.

6. To return to the 'Report Designer' window, click 'Close'.

The Details section is now removed from your report layout.

The report layout should now look as follows:
           

You are now ready to remove the column headings you no longer require on your report.

To remove the column headings you no longer require on your Customer 
Histories Over Credit Limit report

1. Select the 'Tran Number' column heading.
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The cursor changes to a cross shape.

2. Press the DELETE key to remove the column heading from your report.

Repeat the above steps for the following column headings:

'Tran Number', 'Type', 'Date', 'Details'.

You are now ready to re-arrange the text and variable objects on your Customer Histories 
Over Credit Limit report.

To rearrange the text and variable objects on your Customer Histories Over 
Credit Limit report

1. Select the 'NET_AMOUNT' variable.

The cursor changes to a cross shape.

2. Using the arrow keys, move the 'NET_AMOUNT' variable to the new position on your 
report.

Repeat these steps to move the 'TAX_AMOUNT' and 'GROSS_AMOUNT' variables and 
the 'Net Amount', 'Tax Amount' and 'Gross Amount' column headings until your report 
looks like the following:

           

You should now save and print your report.

Your printed report should look similar to the following:
           

Congratulations, you have now completed all the example reports. Why not try creating 
some reports of your own?
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Glossary of Report Designer Terms
In this chapter:
Glossay of Terms .............................181
This chapter contains definitions for 
frequently used Report Designer terms.



Remember....
We have also included a Glossary of Report Designer terms in your Sage Report Designer 
Help system.

To view the glossary, select the Glossary button on the help window toolbar. Alternatively, 
click the Index tab from the on-screen help and type glossary into the space provided.

           



 Glossary of Report Designer Terms
Glossay of Terms

A
          

C
          

Active Complete The Active Complete option automatically adds titles and totals for 
variables that are added to a report.

Anchoring Objects Anchoring an object prevents the object from being moved 
accidentally on a report. This is particularly useful when aligning 
objects on a report layout to correctly print on stationery.

ANSI file format American National Standards Institute. A type of output standard.

Auto Sizing The auto sizing option recalculates the size of an object. For 
example, if you change the font size of an object, auto sizing 
prevents the object border cutting off the text and makes sure all 
the text appears on the report.

Alignment The Report Designer's 'Alignment' option enables horizontal or 
vertical alignment of several objects at once. In addition, any 
objects that have moved out of the set margins can be brought 
back automatically.

Criteria Use the Report Designer's 'Criteria' option to be more selective 
about the records you want to print out.

For each report you create, you can set up a pre-set criteria, so 
that each time you run the report it uses the same criteria. For 
example, you may always want to run the same report with a 
reference between A001 to A999.

Conditional Properties / 
View

Use this option to format an object, based on its value, or that of 
another variable.

CSV Output Sage Standard CSV output (Comma Separated Value) is a way of 
producing a file where the text is enclosed by quotation marks '', 
the numeric values are not enclosed by any marks, all fields are 
padded to the maximum data base size and all fields are separated 
by a comma when running a report.
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D
          

E
          

F
          

Date The Date option enables you to set up a default format for the Date 
variables required on reports. The date format can also be applied 
to an individual variable.

Delimited CSV Output This is similar to CSV output, but you have more flexibility over how 
the output file is created, so you can match it to virtually any other 
package you want to import data into. It offers more control over 
the separator, text and numeric qualifiers, fixed length and file 
extension applied to each variable.

Details Section The Details section contains the body of the report and is printed 
on every page of the report.

Document Type This can be a Letter, Label, Layout or Report.

Expressions An expression is a variable calculated from information in other 
existing variables (and numbers)

Filters The Filter option allows you to be more selective about the records 
or transactions you want to include in your report. This is similar to 
criteria except that it embeds the selection in the report.

Fixed Reports Some of the reports supplied with your Sage program will be 
''fixed''. These are usually important reports that should not be 
overwritten. You can edit fixed reports, but you will be forced to 
save the report under a different name so that the original report 
remains unchanged.
82



 Glossary of Report Designer Terms
G
          

H
          

L
          

Graphics You can use the Report Designer's graphic tools to draw lines or 
rectangles on your report. Each 'graphic object' can be given its 
own background colour (fill), pattern and line border. The lines you 
draw can be any thickness, colour and can be solid or dashed.

You cannot add lines and boxes to stationery layouts.

Group When you create a report, you may want to list all the items relating 
to one variable together. You can list these items by creating a 
group. For example, you could list together all transactions with the 
same date, and provide a group total.

When you add a group to your report, the Report Designer 
automatically creates a header and footer section for this group in 
your layout.

Group Sort Override Enables a group sort to be overridden with another variable from 
the outermost table.

HTML The output of a report can be set so it appears as an HTML 
(Hypertext Mark-up Language) file. A Browser such as Internet 
Explorer must be installed.

Hyperlink A hyperlink enables a jump to another location, and can often be 
recognised by blue underlined text. This location may include an 
e-mail or web address. When a report is output to HTML, the 
hyperlinks become active.

Layouts The Report Designer can be used to create stationery layouts. 
Stationery layouts are designed to be printed onto your every day 
stationery, such as 3 part invoice paper.
 183



Sage Report Designer User’s Guide

1

N
          

O
          

P
          

Navigator The navigator appears on the left hand side of the Report Wizard 
window. The navigator list enables quick selection of sections and 
acts as an indicator to show which section you are working in.

Numeric Qualifier In a CSV or Delimited output file, the numeric qualifier encloses all 
numeric fields within a quotation mark ('') or an inverted comma (') 
depending on the option selected.

Objects An object refers to any item that is placed on a report. For example 
an object could be a piece of text, a value or amount, or a 
graphical object such as a line or box.

Object Tooltips Move the cursor over an abject and additional information is 
displayed.

OEM file format A non-ANSI character set output. (See ANSI definition).

Outermost Table This refers to the report table which shows outermost on the report 
design view.

It can also be seen from the Format menu, Groups window. The 
Outermost Table is the first table shown in the Group column.

Page Footer Section The Page Footer section normally contains the totals for your 
report. The Page Footer section information prints at the end of 
every page.

An extra footer section is created when a group is added to a 
report.
84



 Glossary of Report Designer Terms
R
          

S
          

Page Header Section The Page Header section contains the titles of any columns on 
your report. The Page Header section information prints at the start 
of every page.

An extra header section is created when a group is added to a 
report.

Report Layout The Report Layout is displayed when the user edits or creates a 
new report.

Report Wizard The Report Wizard guides you through creating a new report.

Sections When you create a report, the report Designer automatically 
divides it into sections. A simple report consists of the following 
sections:

Page Header
Details
Page Footer

Sorts The Sorts option sets up the order that the variables appear on the 
report.

String Any value (either number or letter) enclosed in quotation marks.

Styles The style is made from all the characteristics of the text you use in 
your report. You can set up a new style, and apply this to existing 
text. The text displayed instantly takes on the characteristics of the 
new style.
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U
          

V
          

Tables The Report Designer tables hold all the variables available for the 
report. The tables of variables change depending on the type of 
report being created.

Templates The Report Designer template provides an image of the Sage 
stationery you are working on, helping you to place objects in the 
correct positions for printing.

These are stored in separate files called template files and you can 
load one at any time.

Text Qualifier If the Text Qualifier option is enabled, all text fields are enclosed by 
a quotation mark ('') or an inverted comma ('), depending on which 
option is selected.

User Defined Objects A collective term for Text Objects and Expressions on a report 
design.

Variables Variable objects are used to represent specific types of data. When 
the report is printed the data is printed instead of the variable 
object. Variables are grouped into tables
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